HDU-2955-Robberies(01背包,逆向思维)

Robberies

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 27026 Accepted Submission(s): 9959

Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output
2
4
6

Source
IDI Open 2009

Recommend
gaojie


题意

  • 输入一个 t ,表示有 t 组数据。
  • 每组数据先输入 一个 P 和 一个 n
  • P 代表被抓的概率需要低于 Pn 代表有 n 个银行。
  • 接下来 n 行的每行输入一个 wp
  • w 代表当前银行所有的金额,p 代码当前银行被抓的概率。

:小偷在被抓的概率低于 P 的情况下,最多能偷多少钱?


解题思路

  • 被抓概率 = 1 - 不被抓概率,所以只要 不被抓概率 >= 1 - P
  • 01背包
  • dp[i] : 偷到 i 金额的钱,而不被抓的最大概率。
  • dp[0] 初始化为 1.0 , 因为不偷任何东西时,不被转最大概率为 1.0。
  • 转移方程 dp[j]=dp[jw[i]](1.0p[i]);
  • 最后答案就在满足不被抓概率 >= 1 - P 中,取最大金额


代码如下

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;

double dp[10005],p[105];
int w[105];

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        double P;
        int n;
        scanf("%lf %d",&P,&n);
        P = 1.0 - P;
        for(int i = 1;i <= n;i++) scanf("%d %lf",&w[i],&p[i]);
        memset(dp,0,sizeof(dp));
        dp[0] = 1.0;
        for(int i = 1;i <= n;i++){
            for(int j = 10000;j >= w[i];j--){
                if(dp[j] < dp[j - w[i]] * (1.0 - p[i])){
                    dp[j] = dp[j - w[i]] * (1.0 - p[i]);
                }
            }
        }
        int sum = 0;
        for(int i = 0;i <= 10000;i++){
            if(dp[i] >= P) sum = max(sum,i);
        }
        printf("%d\n",sum);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值