C - Constructing Roads

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output
179

import java.io.BufferedInputStream;
import java.util.PriorityQueue;
import java.util.Scanner;

public class Main{ 
	/* [8.3~8.9]最小生成树
	 * A - Jungle Roads 
	 * */
	static final int N=(int)1e2+10,M=N<<1;
	static int []fa,x,y,Size;
	static int n;
	static int sum;
	static int g[][];
	static PriorityQueue<node>q=new PriorityQueue<node>();
	
	public static void main(String[] args) {
		
		Scanner sc=new Scanner(new BufferedInputStream(System.in));
		int e,v,s,b;
		init();
//		int t=sc.nextInt();
		while(sc.hasNext()) {
			n=sc.nextInt();
			kruskal_init(n);
			//记录边的信息
			for(int i=1;i<=n;i++) {
				for(int j=1;j<=n;j++) {
					g[i][j]=sc.nextInt();
				}
			}
			int Q=sc.nextInt();
			for(int i=1;i<=Q;i++) {
				e=sc.nextInt();
				v=sc.nextInt();
				g[e][v]=g[v][e]=0;
			}
			for(int i=1;i<=n;i++) {
				for(int j=1;j<i;j++) {
					q.add(new node(i,j,g[i][j]));
				}
			}
			Kruskal();
		}
	}
	static void Kruskal() {
		//合并
		while(!q.isEmpty()) {
//			Union(q.poll());
			node no=q.poll();
			int l=find(no.s);
			int r=find(no.e);
			if(l!=r) {
				fa[l]=r;
				sum+=no.v;
			}
		}
		System.out.println(sum);
	}
	static void kruskal_init(int n) {
		q.clear();
		//并查集初始化。
		for(int i=0;i<=n;i++) {
			fa[i]=i;
//			Size[i]=1;
		}
		sum=0;
	}
	static double col(int i,int j) {
		return Math.sqrt(Math.pow(x[i]-x[j], 2)+Math.pow(y[i]-y[j], 2));
	}
	static int find(int x) {
		if(fa[x]==x) return x;
		return (fa[x]=find(fa[x]));
	}
	static void init() {
//		Size=new int[N];
//		x=new int [N];
//		y=new int [N];
		fa=new int [N];
		g=new int [N][N];
	}
	static class node implements Comparable<node>{
		int s,e;
//		double v;
//		public node(int s,int e,double v) {
//			this.s=s;this.e=e;this.v=v;
//		}
		
		int v;
		public node(int s,int e,int v) {
			this.s=s;this.e=e;this.v=v;
		}
		public int compareTo (node o) {
			if(this.v>o.v) return 1;
			else if(this.v==o.v) return 0;
			return -1;
//			if( this.u<o.u) return ;
		}
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值