Constructing Roads POJ - 2421(克鲁斯卡尔)

Constructing Roads

  POJ - 2421

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output
179

题意:给出一共有n个城市,下面n*n的矩阵代表各点之间的距离,下面给出m,下面m行每行有两个数,代表有m条路径已经连通,求还需要修建多少距离能让所有城市都连通。

思路:MST,把已经连通的长度记为0,把两个端点加入集合

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 605
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define mod 1000000007
#define P pair<int,int>
using namespace std;

int n,m,k;
int maze[maxn][maxn];
int par[maxn];
int ranknum[maxn];

struct Edge{
    int s;
    int e;
    int len;
}E[maxn];
bool cmp(Edge x,Edge y){
    return x.len<y.len;
}
//并查集
void init(int n)
{
    for(int i=1;i<=n;++i){
        par[i] = i;
        ranknum[i] = 0;
    }
}
int findpar(int x)
{
    if(par[x]==x) return x;
    return par[x] = findpar(par[x]);
}
void unite(int x,int y)
{
    int fx = findpar(x);
    int fy = findpar(y);
    if(fx == fy) return ;
    if(ranknum[fx]<ranknum[fy]){
        par[fx] = fy;
    }
    else{
        par[fy] = fx;
        if(ranknum[fx]==ranknum[fy])
            ranknum[fx]++;
    }
}
 int kruskal()
 {
    int sum=0;
    for(int i=1;i<=k;++i){
        if(findpar(E[i].s)==findpar(E[i].e)) continue;
        unite(E[i].s,E[i].e);
        sum += E[i].len;
    }
    return sum;
 }
int main()
{
    while(scanf("%d",&n)!=EOF){
        k = 0;
        for(int i=1;i<=n;++i){
            for(int j=1;j<=n;++j){
                scanf("%d",&maze[i][j]);
                if(j>i){
                    E[++k].s = i;
                    E[k].e = j;
                    E[k].len = maze[i][j];
                }
            }
        }
        init(n);
        scanf("%d",&m);
        int x,y;
        while(m--){  //把已经联通的边长度改为0,把顶点加入集合
            scanf("%d %d",&x,&y);
            for(int i=0;i<=k;++i){
                if((E[i].s==x&&E[i].e==y)||(E[i].s==y&&E[i].e==x)){
                    E[i].len = 0;
                    break;
                }
            }
            unite(x,y);
        }
        sort(E+1,E+k+1,cmp);
        printf("%d\n",kruskal());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值