Stars

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
请添加图片描述

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0

分析

题意: 笛卡尔坐标系中有n个点,每个点都有一个层次。第i个点的层次为坐标系中x轴、y轴坐标局小于等于自己的点(不包括自己)的个数。

如图:
层次为0的有1个点(点1)
层次为1的有2个点(点2和点4)
层次为2的有1个点(点3)
层次为3的有1个点(点5)
层次为4的有0个点

题解:
算法:树状数组。
“ 星星按Y坐标升序排列。Y坐标相等的星星按X坐标升序排列。”所以只用考虑x坐标。按x坐标累计树状数组。

import java.io.BufferedInputStream;
import java.util.Arrays;
import java.util.Scanner;

public class Main{ 
	static int N=15005,X=32005;
	static int []d=new int [X];//树状数组 d[i]表示x坐标便面比它小的个数、
	static int []cnt=new int [N];//统计结果 cnt[i]表示第i颗星星所拥有的level
	static int n;
	public static void main(String[] args) {
		Scanner sc=new Scanner(new BufferedInputStream(System.in));
		while(sc.hasNext()) {
			Arrays.fill(d, 0);
			Arrays.fill(cnt, 0);
			n=sc.nextInt();
			int x,y;
			for(int i=1;i<=n;i++) {
				x=sc.nextInt();y=sc.nextInt();
				//x+1是为了避免0,x可能为0. 因为树状数组下标为0的位置不可用。
				cnt[getsum(x+1)]++;
				add(x+1,1);
			}
			for(int i=0;i<n;i++) System.out.println(cnt[i]);
		}
	}
	static int lowbit(int x) {
		return x&(-x);
	}
	static void add(int x,int v) {//将第i位置加上v,那么它的父节点也要加v
		while(x<=X) {
			d[x]+=v;
			x+=lowbit(x);//i的父节点。要加上全部都要加上。
		}
	}
	static int getsum(int x) {//query 
		int res=0;
		while(x>0) {
			res+=d[x];
			x-=lowbit(x);//i的前驱。
		}
		return res;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值