java—学生类

Description

有一个学生类的结构如下:
class Student {
	private int no;
	private String name;
        private int score;
	
	public Student(int _no, String _name, int _score) {
		no = _no;
		name = _name;
                score = _score;
	}
        public int getNo() {return no;}
        public String getName() {return name;}
        public int getScore() {return score;}
	
	public void print(){
		System.out.println(no + " "+name+" "+score);
	}
}

请构造main函数完成如下功能:
从键盘中读入三个学生的信息,比较他们的成绩,按照成绩由高到低排列输出

Input

三个学生的学号、姓名、成绩

Output

由高到低排列输出的三个学生信息

Sample Input

1 wang 89
2 liu 78
3 ma 90

Sample Output

3 ma 90
1 wang 89
2 liu 78
import java.util.*;

public class Main {

    public static void main(String[] args) {

        Scanner input=new Scanner(System.in);

        Student s[]=new Student[4];

        for(int i=0;i<3;i++) {

            int a=input.nextInt();

            String n =input.next();

            int b=input.nextInt();

            s[i]=new Student(a,n,b);

        }

        for(int i=0;i<=2;i++) {

            for(int j=i+1;j<3;j++)

            if(s[i].getScore()<s[j].getScore()) {

                Student ss=new Student(0,"",0);

                ss=s[i];

                s[i]=s[j];

                s[j]=ss;

            }

        }

        for(int i=0;i<=2;i++) {

            s[i].print();

        }

    }

}
  • 1
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值