第二次用链表,約賀付数,还可以再简单的方法做

Problem I

Time Limit : 20000/10000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 6   Accepted Submission(s) : 5
Problem Description
Recently you must have experienced that when too many people use the BBS simultaneously, the net becomes very, very slow.
To put an end to this problem, the Sysop has developed a contingency scheme for times of peak load to cut off net access for some buildings of the university in a systematic, totally fair manner. Our university buildings were enumerated randomly from 1 to  n. XWB is number 1, CaoGuangBiao (CGB) Building is number 2, and so on in a purely random order.
Then a number  m would be picked at random, and BBS access would first be cut off in building 1 (clearly the fairest starting point) and then in every  mth building after that, wrapping around to 1 after  n, and ignoring buildings already cut off. For example, if  n=17 and  m=5, net access would be cut off to the buildings in the order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7]. The problem is that it is clearly fairest to cut off CGB Building last (after all, this is where the best programmers come from), so for a given  n, the random number  m needs to be carefully chosen so that building 2 is the last building selected.

Your job is to write a program that will read in a number of buildings n and then determine the smallest integer m that will ensure that our CGB Building can surf the net while the rest of the university is cut off.

Input Specification

The input file will contain one or more lines, each line containing one integer  n with 3 <=  n < 150, representing the number of buildings in the university.
Input is terminated by a value of zero (0) for  n.

Output Specification

For each line of the input, print one line containing the integer  m fulfilling the requirement specified above.

Sample Input

3
4
5
6
7
8
9
10
11
12
0

Sample Output

2
5
2
4
3
11
2
3
8
16
 

AC代码:

#include <stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
using namespace std;


struct LNode{
int data;          
LNode *next;
};
void InitList_Sq(LNode *l)         //创建线性表

      int n,i,m,l1,j,k; 
     
     while(cin>>n&&n!=0)
    { 
          LNode *p=NULL,*r=NULL,*h=NULL;  //临时指针变量
         
          for(l1=2;;l1++)  
        {
              while(1)  
              {
                   r=l;
                   for(i=2;i<=n;i++)
                  {
                   p=(LNode*)malloc(sizeof(LNode));
                     p->data=i;      
                     p->next=NULL; r->next=p; r=p;
                  }
 
                  r->next=l->next;
                  m=n-1;//因为把数字1省去了,所以少一个数字
                  
                 
                     
                      while(m!=1)
                      { 
                          j=l1;
                          j--;
                        while(j--)
                            r=r->next;
                        h=r->next;
//cout<<"ppp"<<h->data<<endl;
//if(h->data==2){l1++;break;}    //这里需要l1++!!!!!!!!
                        r->next=h->next;
// cout<<r->data<<endl;
                        m--;
                      }
                      
                      if(m==1)
                      {
                        if(r->data==2)
                        {
                          cout<<l1<<endl;
                          k=1;
                          r->next=NULL; 
                          break;
                                           
                        }
                        else 
                        {
// cout<<"pppppppp"<<r->data<<endl;
                            k=0;   //这里要注意将k清零,不然的话,接下来k会一直都是1!!!!!
                             break;
                             r->next=NULL;
                      
                        }
 }
 }
              if(k==1)break; 
                           
    } 
    
   } 
  
}
  
  




int  main()
{
    LNode *l;
    int e;
    l=(LNode*)malloc(sizeof(LNode)); //头节点
    l->next=NULL;
    InitList_Sq(l);
    return 0;




}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值