HDU2141-Can you find it?

1 篇文章 0 订阅

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 32126    Accepted Submission(s): 8011


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 

Author
wangye
 

Source
 

Recommend
威士忌

思路:暴力解复杂度o(LMNS), 大约10^11,所以会超时,采用分治思想,将A+B+C=X,转化为A+B=X-C;算出A+B的数组,从数组中二分查X-C;这样时间复杂度降为O(LN+MS*log(LN)), 约等于O(LN+MS);就不会超时了;
#include<cstdio>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int maxn=505;
int a[maxn], b[maxn], c[maxn], x[2*maxn], ab[maxn*maxn];
int l, n, m, s, cnt1, cas=0;

bool binarySearch(int tgt)
{
	int l=1, r=cnt1, mid;
	while(r>=l)
	{
		mid=(l+r)>>1;
		if(ab[mid]==tgt)
		return true;
		else if(ab[mid]>tgt)
			r=mid-1;
		else
			l=mid+1;
	}
	return false;
}

int main(){
	while(~scanf("%d%d%d", &l, &n, &m))
	{
		cnt1=0;
		for(int i=1; i<=l; i++)
		scanf("%d", a+i);
		for(int i=1; i<=n; i++)
		scanf("%d", b+i);
		for(int i=1; i<=m; i++)
		scanf("%d", c+i);
		scanf("%d", &s);
		for(int i=1; i<=s; i++)
		scanf("%d", x+i);
		printf("Case %d:\n", ++cas);
		for(int i=1; i<=l; i++)
			for(int j=1; j<=n; j++)
				ab[++cnt1]=a[i]+b[j];
		sort(ab+1, ab+1+cnt1);
		for(int i=1; i<=s; i++)
		{
			int flag=1;
			for(int j=1; j<=m; j++)
			{
				if(binarySearch(x[i]-c[j])==true)
				{
					printf("YES\n");
					flag=0;
					break;
				}
			}
			if(flag)
				printf("NO\n");
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值