hdu 1002之大数加法

7 篇文章 0 订阅
4 篇文章 0 订阅

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 404581    Accepted Submission(s): 78406


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
 
 
21 2112233445566778899 998877665544332211
 

Sample Output
 
 
Case 1:1 + 2 = 3Case 2:112233445566778899 + 998877665544332211 = 1111111111111111110

显然这道题的做法不可能是直接让你a+b,而是让你通过数组模拟激发的过程,因此,我们需要一个转化,先把数据转化成为字符串,每个字符减去'0'再存入到整形数组中,倒序相加,满十进一即可,下面放代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std; 
char a[1005],b[1005];//字符数组 
int ans1[1005],ans2[1005];
int main()
{
	int t;
	scanf("%d",&t);
	int d=1;
	while(t--)
	{
		memset(ans1,0,sizeof(ans1));
		memset(ans2,0,sizeof(ans2));
		scanf("%s",&a);
		scanf("%s",&b);
		int l1=strlen(a);
		int l2=strlen(b);
		for(int i=l1-1,j=0;i>=0;i--,j++)
		{
			ans1[j]=a[i]-'0';//转化为整形数组 
		}
		for(int i=l2-1,j=0;i>=0;i--,j++)
		{
			ans2[j]=b[i]-'0';//同上 
		}
		for(int i=0;i<l1||i<l2;i++)
		{
			ans1[i]+=ans2[i];//关键部分 
			if(ans1[i]>9)
			{
				ans1[i]-=10;//满十进一 
				ans1[i+1]++;
			}
		}
		printf("Case %d:\n",d++);
		printf("%s + %s = ",a,b);
		for(int i=max(l1,l2)-1;i>=0;i--)
		{
			printf("%d",ans1[i]);//输出答案 
		}
		printf("\n");
		if(t)
		{
			printf("\n");//注意格式 错了好几次 QAQ
		}
	}
	return 0;
 } 


新手上路,请各位大佬多多指教。



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值