[HDU 2586] How far away ?(利用LCA求树上任意两点的最短距离)

How far away ?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23628 Accepted Submission(s): 9391

Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this “How far is it if I want to go from house A to house B”? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path(“simple” means you can’t visit a place twice) between every two houses. Yout task is to answer all these curious people.

Input
First line is a single integer T(T<=10), indicating the number of test cases.
For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k).The houses are labeled from 1 to n.
Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.

Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

Sample Input

2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1

Sample Output

10
25
100
100

Source
ECJTU 2009 Spring Contest

Recommend
lcy

LCA是个好东西,由于该题是树形结构,我们另 dis[i] d i s [ i ] 表示i节点到根节点的距离。
我们利用 DFS D F S 求得 dis[i] d i s [ i ] 和每点的深度 ran[i] r a n [ i ] ,求出 lca l c a ,那么 a a ,b的最
短距离就等于: dis[a]+dis[b]2dis[lca(a,b)] d i s [ a ] + d i s [ b ] − 2 ∗ d i s [ l c a ( a , b ) ]

#include<iostream>
#include<vector>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 100050;
vector<int> e[maxn];
vector<int> w[maxn];
int ran[maxn];
int par[maxn];
int dis[maxn];
void init(int n){
    for(int i=1;i<=n;i++){
        par[i]=i;
        e[i].clear();
        w[i].clear();
    }
}
void dfs(int rt){
    ran[rt]=ran[par[rt]]+1;
    int size=e[rt].size();
    for(int i=0;i<size;i++){
        dis[e[rt][i]]=dis[rt]+w[rt][i];
        dfs(e[rt][i]);
    }
}
int lca(int a,int b){
    if(ran[a]>ran[b]) swap(a,b);
    while(ran[a]!=ran[b]){
        b=par[b];
    }
    if(a==b) return a;
    while(par[a]!=par[b]){
        a=par[a];
        b=par[b];
    }
    return par[a];
}
int main(){
    int t,n,a,b,q,c;
    cin>>t;
    while(t--){
        cin>>n>>q;
        init(n);
        for(int i=1;i<=n-1;i++){
            cin>>a>>b>>c;
            e[a].push_back(b);
            w[a].push_back(c);
            par[b]=a;
        }
        for(int i=1;i<=n;i++){
            if(i==par[i]){
                ran[i]=0;
                dis[i]=0;
                dfs(i);
                break;
            }
        }
        // for(int i=1;i<=n;i++){
        //  cout<<i<<" "<<ran[i]<<" "<<dis[i]<<endl;
        // }
        while(q--){
            cin>>a>>b;
            cout<<dis[a]+dis[b]-2*dis[lca(a,b)]<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值