HDU 4135 Co-prime(质因数分解+容斥原理)

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6969    Accepted Submission(s): 2751


 

Problem Description

Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.

 

 

Input

The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 1015) and (1 <=N <= 109).

 

 

Output

For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.

 

 

Sample Input

 

2 1 10 2 3 15 5

 

 

Sample Output

 

Case #1: 5 Case #2: 10

Hint

In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 

 

从A到B中与n互质的数有多少。

利用容斥求出1-B中与n互质的个数,以及1-(A-1)中与n互质的个数,然后相减+1(1与任何数都互质,减去了两次,因此需要+1)即可。

#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
#define maxn 100005

ll re[maxn];
ll k;
ll gcd(ll a,ll b) {
	return b?gcd(b,a%b):a;
}
ll lcm(ll a,ll b)
{
	return a/gcd(a,b)*b;
}
void primefactor(ll n)
{
	k=0;
	for(ll i=2;i*i<=n;i++)
	{
		if(n%i==0)
		{
			re[k++]=i;
			while(n%i==0)
			{
				n/=i;
			}
		}
	}
	if(n!=1)
	{
		re[k++]=n;
	}
}
int main()
{
	ll n,t,a,b;
	cin>>t;
	ll ci=1;
	while(t--)
	{
		cin>>a>>b>>n;
		ll d=n;
		primefactor(n);
		ll ans1=0;
		ll ans2=0;
		for(ll i=1;i<(1 << k);i++)
		{
			ll cnt=0;
			ll temp=1;
			for(ll j=0;j<k;j++)
			{
				if(i >> j & 1)
				{
					cnt++;
					temp=lcm(temp,re[j]);
				}
			}
			if(cnt&1) ans1+=b/temp;
			else ans1-=b/temp;
		}
		ans1=b-ans1;
		for(ll i=1;i<(1 << k);i++)
		{
			ll cnt=0;
			ll temp=1;
			for(ll j=0;j<k;j++)
			{
				if(i >> j & 1)
				{
					cnt++;
					temp=lcm(temp,re[j]);
				}
			}
			if(cnt&1) ans2+=(a-1)/temp;
			else ans2-=(a-1)/temp;
		}
		ans2=a-ans2;
		cout<<"Case #"<<ci++<<": "<<ans1-ans2+1<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值