【HDU 2196】Computer (树形dp)

Computer
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 33469 Accepted Submission(s): 5009

Problem Description
A school bought the first computer some time ago(so this computer’s id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.

Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).

Sample Input
5
1 1
2 1
3 1
1 1

Sample Output
3
2
3
4
4

这是一道据说是树形dp入门的题目(Orz),然后研究了好久,终于差不多弄懂了。
对于树上的一个点来说,它的最远距离只能有两种,一种是它的子节点方向的距离
L1和沿父亲节点方向的距离L2,那么最终的答案应该就是max( L1,L2)

对于L1,我们直接往下DFS,然后再回溯即可:
vu的子节点,假设F[i]i点的L1值,那么
F[u]=max(F[u],F[v]+W(u,v))
对于L2,我们先往上找,令p[i]i的父节点,g[u]为沿父节点方向的最大值
那么g[u]=max(g[u],f[v]+W[v,p[u]]),然后递归的求出来每个点的g[u]即可。`

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
const int maxn = 100500;
int g[maxn];//沿父亲方向的最大距离
int f[maxn];//沿子节点方向的最大距离
int p[maxn];//i的父节点
struct node
{
    int v,w;
    node(int a,int b)//构造函数
    {
        v=a;
        w=b;
    }
};
vector<node> e[maxn];//边
void dfs1(int u,int pre)//求f[i];
{
    int len=e[u].size();
    for(int i=0;i<len;i++)
    {
        int v=e[u][i].v;
        if(v!=pre)
        {
            dfs1(v,p[v]=u);
            f[u]=max(f[u],f[v]+e[u][i].w);
        }
    }
}
void dfs2(int u,int pre)//求g[i];
{
    int t=0;
    g[u]=g[pre];
    int len=e[pre].size();
    for(int i=0;i<len;i++)
    {
        int v=e[pre][i].v;
        if(v==p[pre]) continue;
        if(v==u) t=e[pre][i].w;
        else g[u]=max(g[u],f[v]+e[pre][i].w);
    }
    g[u]+=t;
    for(int i=0;i<e[u].size();i++)
    {
        int v=e[u][i].v;
        if(v!=pre)
        {
            dfs2(v,u);
        }
    }
}
int main()
{
    int n;
    while(cin>>n)
    {
        for(int i=1;i<=n;i++) e[i].clear();
        f[1]=g[1]=p[1]=0;
        int a,b;
        for(int u=2;u<=n;u++)
        {
            cin>>a>>b;
            e[u].push_back(node(a,b));//构图
            e[a].push_back(node(u,b));
            f[u]=g[u]=p[u]=0;
        }
        dfs1(1,0);
        dfs2(1,0);
        for(int i=1;i<=n;i++)
        {
            cout<<max(f[i],g[i])<<endl;//输出即可
        }
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值