[C/C++] 1046 Shortest Distance (20 分)

1046 Shortest Distance (20 分)The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.Input Specific...
摘要由CSDN通过智能技术生成

1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5]), followed by N integer distances D1D2⋯ DN, where Di​​ is the distance between the i-th and the (i+1)-st exits, and DN​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

#include<stdio.h>

int main()
{
	int n,m;
	scanf("%d",&n);
	int dst[n+1];
	int sum = 0;
	for(int i=1; i<=n; i++){
		scanf("%d",&dst[i]); 
		sum += dst[i];
	} 
	scanf("%d",&m);
	int start,end,short_path;
	for(int i=0; i<m; i++){
		scanf("%d%d",&start, &end);
		if( start>end ){
			int t = start;
			start = end;
			end = t;
		}
		int one = 0,another = 0;
		for(int j=start;j<end;j++){
			one += dst[j];
		}
		another = sum - one;
		printf("%d\n",one<another?one:another);
	}
		
	return 0;
}

^ 测试点2运行超时 (极端情况,105 * 104 = 109),不经过预处理很容易超时
2.在这里插入图片描述

#include<stdio.h>

int main()
{
	int n,m;
	scanf("%d",&n);
	int dst[n] = {0};//dst[i]表示1到i+1的路长 
	int sum = 0,d;
	for(int i=1; i<=n; i++){
		scanf("%d",&d); 
		dst[i] = dst[i-1] + d;
		sum += d; 
	} 
	scanf("%d",&m);
	int start,end;
	for(int i=0; i<m; i++){
		scanf("%d%d",&start, &end);
		if( start>end ){
			int t = start;
			start = end;
			end = t;
		}
		int one;
		one = dst[end-1] - dst[start-1];
		printf("%d\n",one<another?one:sum - one);
	}
		
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
当然可以!以下是一个用C++实现Dijkstra算法的图地铁最短路径项目的示例代码: ```cpp #include <iostream> #include <vector> #include <queue> using namespace std; #define INF 9999 // 图的节点类 class Node { public: int id; int distance; bool visited; vector<pair<int, int>> neighbors; // 邻居节点及边的权重 Node(int _id) { id = _id; distance = INF; visited = false; } void addNeighbor(int neighbor, int weight) { neighbors.push_back(make_pair(neighbor, weight)); } }; // 图类 class Graph { public: vector<Node> nodes; // 添加节点 void addNode(Node node) { nodes.push_back(node); } // 添加边 void addEdge(int src, int dest, int weight) { nodes[src].addNeighbor(dest, weight); nodes[dest].addNeighbor(src, weight); } // Dijkstra算法 void shortestPath(int start) { priority_queue<pair<int, int>, vector<pair<int, int>>, greater<pair<int, int>>> pq; // 初始化起点 nodes[start].distance = 0; pq.push(make_pair(0, start)); while (!pq.empty()) { int u = pq.top().second; pq.pop(); if (nodes[u].visited) continue; nodes[u].visited = true; for (auto neighbor : nodes[u].neighbors) { int v = neighbor.first; int weight = neighbor.second; if (nodes[v].distance > nodes[u].distance + weight) { nodes[v].distance = nodes[u].distance + weight; pq.push(make_pair(nodes[v].distance, v)); } } } } }; int main() { Graph graph; // 添加节点 for (int i = 0; i < 6; i++) { Node node(i); graph.addNode(node); } // 添加边 graph.addEdge(0, 1, 7); graph.addEdge(0, 2, 9); graph.addEdge(0, 5, 14); graph.addEdge(1, 2, 10); graph.addEdge(1, 3, 15); graph.addEdge(2, 3, 11); graph.addEdge(2, 5, 2); graph.addEdge(3, 4, 6); graph.addEdge(4, 5, 9); int start = 0; graph.shortestPath(start); // 输出最短路径 for (int i = 0; i < graph.nodes.size(); i++) { cout << "最短路径从节点 " << start << " 到节点 " << i << " 的距离为:" << graph.nodes[i].distance << endl; } return 0; } ``` 上述代码实现了一个简单的图类和节点类,使用 Dijkstra 算法计算了图中每个节点到起点的最短路径。你可以根据自己的需求进行修改和扩展。注意,这只是一个简单的示例,实际项目中可能需要更复杂的数据结构和算法来表示和计算地铁线路。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值