7-4 数据结构实验之链表四:有序链表的归并

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

输入格式:

第一行输入M与N的值。(1 <= M <=100000, 1 <= N <= 100000)

第二行依次输入M个有序的整数。

第三行依次输入N个有序的整数。

输出格式:

输出合并后的单链表所包含的M+N个有序的整数。

输入样例:

6 5
1 23 26 45 66 99
14 21 28 50 100

输出样例:

1 14 21 23 26 28 45 50 66 99 100

 

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node*next;
};
struct node*creat(int m)
{
    struct node*head,*p,*tail;
    head=(struct node*)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    for(int i=1;i<=m;i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head;
}
void hebing(struct node*head1,struct node*head2)
{
    struct node *p,*q,*tail;
    p=head1->next;
    q=head2->next;
    tail=head1;
    head1->next=NULL;
    free(head2);
    while(p&&q)
    {
        if(p->data<=q->data)
        {
            tail->next=p;
            tail=p;
            p=p->next;
        }
        else
        {
            tail->next=q;
            tail=q;
            q=q->next;
        }

    }
    if(p)
    {
        tail->next=p;
    }
    else
    {
        tail->next=q;
    }
}
void output (struct node *p)
{
    struct node *i;
    for(i = p; i != NULL; i = i->next)
    {
        printf("%d", i->data);
        if(i->next != NULL) printf(" ");//格式
        else printf("\n");
    }
}
int main()
{
    int m,n;
    scanf("%d%d",&m,&n);
    struct node*head1,*head2;
    head1=creat(m);
    head2=creat(n);
    hebing(head1,head2);
    output(head1->next);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值