HDU 2095 find your present (2)

 

find your present (2)

Time Limit: 1000/2000 MS (Java/Others)    Memory Limit: 32768/1024 K (Java/Others)
Total Submission(s): 6852    Accepted Submission(s): 2509


Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 

Input
The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

Output
For each case, output an integer in a line, which is the card number of your present.
 

Sample Input
  
  
5 1 1 3 2 2 3 1 2 1 0
 

Sample Output
  
  
3 2
Hint
Hint
use scanf to avoid Time Limit Exceeded
 

Author
8600
 

Source
 

Recommend
8600
 
 
呢个题目,我用左我地一个师兄叫linda既牛人既一种异或运算既妙用。
其实就系一个数n,  n^n = 0 即系如果有累异或变量tsu 对n 进行偶数次异或,甘样 tsu = 0。
另一方面如果进行奇数次异或,tsu = n。
尼条题目就系要搵到出现奇数次既数字,所以直接不断异或就ok。
 
贴代码:
43138132011-08-02 16:08:28Accepted2095218MS188K227 BC++10SGetEternal{(。)(。)}!
#include <iostream>
using namespace std;

int main()
{
    int n, a, pre;

    while (scanf("%d", &n), n)
    {
        pre = 0;
        while (n--)
        {
            scanf("%d", &a);
            pre ^= a;
        }
        printf("%d\n", pre);
    }

    return 0;
}

代码系够短,不过^运算其实系好费时间噶。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值