hdoj 1034 Candy Sharing Game 【水模拟】【周赛】

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4440    Accepted Submission(s): 2710


Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy. 
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
 

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
 

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.
 

Sample Input
  
  
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
 

Sample Output
  
  
15 14 17 22 4 8
Hint
The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1035  1031  1038  1015  1018 
 

Statistic |  Submit |  Discuss |  Note

思路:

            纯模拟!
            首先要读懂题意,因为题上说当吹过口哨的时候同学们要一起将手里面的糖果一半都给它的右边的同学,然后如果给过之后,如果谁的手里面的糖果的个数是奇数那么老师将再给你一个,重新吹哨,直到所有的同学手里面的糖果的个数相同的时候就结束活动,然后将吹哨的次数和同学们手里面的糖果的个数都输出在同一行!

代码:

<pre name="code" class="cpp">#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int a[50005];
int n;
int f()
{
	for(int i=1;i<n;i++)
	{
		if(a[i]!=a[i-1])
		{
			return 1;
		}
	}
	return 0;
}
int main()
{
	while(scanf("%d",&n)&&n)
	{
		int cnt=0;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		while(f())
		{
			cnt++;
			int t=a[n-1]/2;//首先先将a[n-1]的一半的个数保存,因为当它左边的 
			a[n-1]/=2;//人给她的时候,那么它的个数就会发生变化,所以先保存,并且减半! 
			for(int i=n-1;i>0;i--)
			{
				a[i]+=a[i-1]/2;//给的过程是先给别人并且自己的个数减半 
				a[i-1]/=2;
				if(a[i]%2==1)
				{
					a[i]++;
				}
			}
			a[0]+=t;//最后将最后一个人的糖果数加到第一个人上面 
			if(a[0]%2==1)//判断是否用老师给他 
			{
				a[0]++;
			}
		}
		printf("%d %d\n",cnt,a[0]);
	}
	return 0;
}


 
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值