hdoj 5630 Rikka with Chess

Rikka with Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 499    Accepted Submission(s): 416


Problem Description
Yuta gives Rikka a chess board of size  n×m .

As we all know, on a chess board, every cell is either black or white and every two cells that share a side have different colors.

Rikka can choose any rectangle formed by board squares and perform an inversion, every white cell becomes black, and vice versa.

Rikka wants to turn all cells into the same color, please tell Rikka the minimal number of inversions she need to achieve her goal.
 

Input
The first line contains a number  T(T10)  ——The number of the testcases.

Each testcase contains two numbers  n,m(n109,m109) .
 

Output
For each testcase, print a single number which represents the answer.
 

Sample Input
  
  
3 1 2 2 2 3 3
 

Sample Output
  
  
1 2 2
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5639  5638  5637  5636  5635 
 

题意:

就是给你一个矩形棋盘,并且这个矩形棋盘上任意一个相邻的正方形上有不相同的颜色,要么是白色,要么是黑色,然后你只有通过翻转将一行或者一列的正方形的颜色进行改变(也就是白的变黑,黑的变白),看你通过多少次翻转能将这个矩形棋盘变成统一的颜色!

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n,m;
		scanf("%d%d",&n,&m);
   		printf("%d\n",n/2+m/2);
	}
return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值