[POJ2407]Relatives

Time Limit: 1000MS
Memory Limit: 65536K

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

题意:求小于n的正整数中,与n互质的数的个数。

题解:
我…dxy….数学学渣。
求phi(n)。phi(n)为欧拉函数。
phi(n)=n(11/p1)(11/p2)...(11/px)
p1,p2,p3…px为n的所有质因数。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#include<cmath>
#define LiangJiaJun main
#define ll long long
using namespace std;
ll n;
ll phi(ll x){
   ll ans=x,now=x,lim=sqrt(x);
   for(int i=2;i<=lim;i++){
       if(now % i == 0){
          ans=ans*(i-1)/i;
          while(now % i==0)now /= i;
       }
   }
   if(now > 1)ans = ans*(now-1)/now;
   return ans;
}

int LiangJiaJun (){
    while(scanf("%lld",&n)){
        if(n == 0)break;
        printf("%lld\n",phi(n));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值