poj1852 Ants

Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8838 Accepted: 3977

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source



说一根棍上有若干蚂蚁,蚂蚁的速度是1cm/s ,已知每个蚂蚁的位置坐标,蚂蚁开始爬,爬到棍子的端点就会下落,爬的过程中遇到蚂蚁就会掉头。这样来判断所有蚂蚁爬完的最短时间和最长时间。

这道题乍一看并没有头绪,但是仔细想一想还是可以想到的。首先,由于所有蚂蚁的速度相同,所以一开始,所有蚂蚁向着自己最短的端点爬去,最后一只蚂蚁(就是离中心最近的蚂蚁)所用时间就是最短时间。

最长时间呢?其实仔细思考下蚂蚁相遇过程就会发现,如果把蚂蚁看做相同的,相遇之后向着相反的方向爬其实就是还按原来的方向爬去。知道了这一点,就不难知道,所有蚂蚁中里某个端点最远的时间即为所用时间。

#include "iostream"

int dir[1000005];

using namespace std;

int main ()
{
    int N;cin >> N;
    while(N--)
    {
        int len,n;
        int max = 0,min = 0;
        cin >> len >> n;
        for (int i = 1;i <= n;i++)
        {
            int t;cin >> t;
            if (2 * t > len)//距离右端点近
            {
                if (len - t > min)//
                    min = len - t;
                if (t > max)
                    max = t;
            }
            else//距离左端点近
            {
                if (t > min)
                    min = t;
                if (len - t > max)
                    max = len - t;
            }
        }
        cout << min <<" " << max << endl;


    }


}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值