Strange fuction

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2949    Accepted Submission(s): 2177


Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2 100 200
 

Sample Output
  
  
-74.4291 -178.8534
 

这就是解方程的题目,但是看到求最小值,应该求导=0,则有极值,发现求导后正好为单调的
#include<stdio.h>
#include<math.h>
double y=0;
double f(double x){
     return  42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x-y;
}
double cal(double x){
     return  6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
int main(){
    freopen("in.txt","r",stdin);
    int zu;
    scanf("%d",&zu);
    while(zu--){
        scanf("%lf",&y);
        double start=0,mid=0,end=100;
        while(end-start>1e-6){
            mid=(start+end)/2;
            if(f(mid)>0){
                end=mid;
            }else{
                start=mid;
            }
        }
        printf("%.4lf\n",cal((start+end)/2));
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值