C - Strange fuction

Description
Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

先求导数,可以看出在0到100区间里面是单峰函数,主要是用二分法求导数为0的地方,注意小数位数,我的代码弄得比较复杂了。
代码如下:

#include <iostream>
#include <cmath>
#include <algorithm>
#include <iomanip>
#define EXP 1e-9
using namespace std;

double y;

double f(double x)
{
    return 42 * pow(x,6) + 48 * pow(x,5) + 21 * pow(x,2) + 10 * x - y;
}

double bs()
{
    double lo = 0, hi = 100;
    double mi, ans = hi + 1;
    while(lo + EXP < hi)
    {
        mi = (lo + hi) / 2.0;
        if(f(mi) < 0)
        {
            lo = mi;
            if(ans = hi + 1)
                ans = mi;
            max(mi, ans);
        }
        else
        {
            hi = mi;
            min(mi, ans);
        }
        //cout << lo << " " << hi << endl;
    }
    //cout << ans << endl;
    if(ans == 100 + 1)
        return -1;
    return ans;
}

int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        cin >> y;
        double temp = bs();
        //cout << temp << endl;
        //cout << fixed << setprecision(5) << (6 * pow(temp,7) + 8 * pow(temp,6) + 7 * pow(temp,3) + 5 * pow(temp,2) - y * temp) * 10000 << endl;
        if(temp != -1.0)
        {
            if((6 * pow(temp,7) + 8 * pow(temp,6) + 7 * pow(temp,3) + 5 * pow(temp,2) - y * temp) * 10000 >= 0)
                cout << fixed << setprecision(4) << (long long)((6 * pow(temp,7) + 8 * pow(temp,6) + 7 * pow(temp,3) + 5 * pow(temp,2) - y * temp) * 10000 + 0.5) / 10000.0 << endl;
            else
                cout << fixed << setprecision(4) << (long long)((6 * pow(temp,7) + 8 * pow(temp,6) + 7 * pow(temp,3) + 5 * pow(temp,2) - y * temp) * 10000 - 0.5) / 10000.0 << endl;
        }
        else
        {
            //cout << "?" << endl;
            if(f(0) >= 0 && f(100) >= 0)
                cout << fixed << setprecision(4) << (double)0 << endl;
            else
                cout << fixed << setprecision(4) << (long long)((6 * pow(100,7) + 8 * pow(100,6) + 7 * pow(100,3) + 5 * pow(100,2) - y * 100) * 10000 - 0.5) / 10000.0  << endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值