POJ2002-Squares

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 15924 Accepted: 6026

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.  

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.  

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

Source

//AC代码
/*
题意:在平面直角坐标系给出n个点,问你能组成多少个正方形
此题因为给出n是最大1000大小,所以不可能暴力(n^4)
所以我们可以退而求其次,因为是正方形如果我们知道其中两个点那么另外两个点我们自然可以求出
公式:
    u.x=node[i].x+(node[i].y-node[j].y);
    u.y=node[i].y-(node[i].x-node[j].x);
    v.x=node[j].x+(node[i].y-node[j].y);
    v.y=node[j].y-(node[i].x-node[j].x);
这样我们可以这两个点创建一个hash表来找另外两个点
*/
#include<iostream>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iomanip>
#include<map>
#include<cstdlib>
#include<cmath>
#include<vector>
#include<set>
#define LL long long
#define IT __int64
#define zero(x) fabs(x)<eps
#define mm(a,b) memset(a,b,sizeof(a))
const int INF=0x7fffffff;
const double inf=1e8;
const double eps=1e-10;
const double PI=acos(-1.0);
const int Max=2001;
using namespace std;
int sign(double x)
{
    return (x>eps)-(x<-eps);
}
typedef struct Node
{
    int x;
    int y;
    Node(const int &_x=0, const int &_y=0) : x(_x), y(_y) {}
    void input()
    {
        cin>>x>>y;
    }
    void output()
    {
        cout<<x<<" "<<y<<endl;
    }
}point;
point node[Max];
int hash[Max<<5];
int next[Max];
double xmult(point p0,point p1,point p2)
{
	return(p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}
bool cmp(point u,point v)
{
    if(u.y<v.y)
        return true;
    else if(u.y==v.y)
    {
        if(u.x<v.x)
            return true;
    }
    return false;
}
bool find(int x,int y)
{
    int value,index;
    value=abs(x+y);
    index=hash[value];
    while(index!=-1)
    {
        if(node[index].x==x&&node[index].y==y)
            return true;
        index=next[index];
    }
    return false;
}
int main()
{
    int n,m,i,j,value,index;
    point u,v;
    int sum;
    //freopen("D:\\in.txt","r",stdin);
    while(cin>>n&&n)
    {
        sum=0;
        //map<int,int>Map_x;
        //map<int,int>Map_y;
        for(i=0;i<n;i++)
        {
            node[i].input();
            //Map_x[node[i].x]=1;
            //Map_y[node[i].y]=1;
        }
        //cout<<Map_x[-1]<<" "<<Map_y[-1]<<endl;
        memset(hash,-1,sizeof(hash));
        memset(next,-1,sizeof(next));
        sort(node,node+n,cmp);
        for(i=0;i<n;i++)
        {
            value=abs(node[i].x+node[i].y);
            next[i]=hash[value];
            hash[value]=i;
        }
        for(i=0;i<n;i++)
        {
            for(j=i+1;j<n;j++)
            {
                u.x=node[i].x+(node[i].y-node[j].y);
                u.y=node[i].y-(node[i].x-node[j].x);
                v.x=node[j].x+(node[i].y-node[j].y);
                v.y=node[j].y-(node[i].x-node[j].x);
                //cout<<u.x<<" "<<u.y<<" "<<v.x<<" "<<v.y<<endl;
                if(find(u.x,u.y)&&find(v.x,v.y))
                    sum+=1;
            }
        }
        cout<<sum/2<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值