2013 - ECJTU 暑期训练赛第四场-problem-J

J - J
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:1000KB     64bit IO Format:%I64d & %I64u

Description

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input

Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output

If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input

     
     
5 3 5 4 6 6 0 0
 

Sample Output

     
     
What a pity! Wonderful! Wonderful!
博弈题,这道题仔细分析,会发现只要n活着m是偶数,那么先手(刚开始都是从(1,m)开始)处在必胜点所以,找到这点,这题不难AC,AC代码:
#include<iostream>
const int MAX=2001;
int s[MAX][MAX];
using namespace std;
int main()
{
	int n,m,sum,i,j,k,t;
	sum=0;
	while(cin>>n>>m&&(n||m))
	{
		if(n%2==0||m%2==0)
		cout<<"Wonderful!"<<endl;
		else
		cout<<"What a pity!"<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值