HDU_2089_不要62

不要62

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 45914    Accepted Submission(s): 17319


Problem Description
杭州人称那些傻乎乎粘嗒嗒的人为62(音:laoer)。
杭州交通管理局经常会扩充一些的士车牌照,新近出来一个好消息,以后上牌照,不再含有不吉利的数字了,这样一来,就可以消除个别的士司机和乘客的心理障碍,更安全地服务大众。
不吉利的数字为所有含有4或62的号码。例如:
62315 73418 88914
都属于不吉利号码。但是,61152虽然含有6和2,但不是62连号,所以不属于不吉利数字之列。
你的任务是,对于每次给出的一个牌照区间号,推断出交管局今次又要实际上给多少辆新的士车上牌照了。
 

Input
输入的都是整数对n、m(0<n≤m<1000000),如果遇到都是0的整数对,则输入结束。
 

Output
对于每个整数对,输出一个不含有不吉利数字的统计个数,该数值占一行位置。
 

Sample Input
  
  
1 100 0 0
 

Sample Output
  
  
80
 

Author
qianneng
 

Source

迎接新学期——超级Easy版热身赛


  • 典型的数位dp
  • 预处理dp[i][j]
  • 第i位是j的全部符合要求的整数(包含0)
  • 因此在cal(n)的时候不会计算n本身
  • 详见代码

#include <iostream>
#include <string>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <climits>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
typedef long long           LL ;
typedef unsigned long long ULL ;
const int    maxn = 1e3 + 10   ;
const int    inf  = 0x3f3f3f3f ;
const int    npos = -1         ;
const int    mod  = 1e9 + 7    ;
const int    mxx  = 100 + 5    ;
const double eps  = 1e-6       ;
const double PI   = acos(-1.0) ;

int dp[8][11], d[10], tot;
void init(void){
	dp[0][0]=1;
	for(int i=1;i<=7;i++)
		for(int j=0;j<10;j++)
			for(int k=0;k<10;k++)
				if(!(j==4) && !(j==6&&k==2))
					dp[i][j]+=dp[i-1][k];
}
int cal(int n){
	tot=0;
	int x=n, res=0;
	while(x){
		d[++tot]=x%10;
		x/=10;
	}
	d[tot+1]=0;
	for(int i=tot;i>0;i--){
		for(int j=0;j<d[i];j++){
			if(d[i+1]!=6 || j!=2){
				res+=dp[i][j];
			}
		}
		if(d[i]==4 || (d[i+1]==6 && d[i]==2)){
			break;
		}
	}
	return res;
}
int u, v;
int main(){
	// freopen("in.txt","r",stdin);
	// freopen("out.txt","w",stdout);
	init();
	while(~scanf("%d %d",&u,&v)){
		if(u==v && u==0){break;}
		printf("%d\n",cal(v+1)-cal(u));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值