HDU3715 Go Deeper

Go Deeper


Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2079 Accepted Submission(s): 685


Problem Description
Here is a procedure's pseudocode:

go(int dep, int n, int m)
begin
output the value of dep.
if dep < m and x[a[dep]] + x[b[dep]] != c[dep] then go(dep + 1, n, m)
end

In this code n is an integer. a, b, c and x are 4 arrays of integers. The index of array always starts from 0. Array a and b consist of non-negative integers smaller than n. Array x consists of only 0 and 1. Array c consists of only 0, 1 and 2. The lengths of array a, b and c are m while the length of array x is n. Given the elements of array a, b, and c, when we call the procedure go(0, n, m) what is the maximal possible value the procedure may output?


Input
There are multiple test cases. The first line of input is an integer T (0 < T ≤ 100), indicating the number of test cases. Then T test cases follow. Each case starts with a line of 2 integers n and m (0 < n ≤ 200, 0 < m ≤ 10000). Then m lines of 3 integers follow. The i-th(1 ≤ i ≤ m) line of them are ai-1 ,bi-1 and ci-1 (0 ≤ ai-1, bi-1 < n, 0 ≤ ci-1 ≤ 2).


Output
For each test case, output the result in a single line.


Sample Input
3
2 1
0 1 0
2 1
0 0 0
2 2
0 1 0
1 1 2


Sample Output
1
1
2


Author
CAO, Peng


Source
2010 Asia Chengdu Regional Contest

题意:要是x数组的两个元素相加不能等于c数组的最大元素个数。。。a,b数组表示在x数组中的位置..

2-SAT..建图还是很好建的。。c数组只有3个值0,1,2,用a表示0,a'表示1.。.。x数组只有0和1,a,b数组代表在x数组中的位置,下面a,b表示的值其实都是x数组的值并不是a,b数组的。

c==0时,a-b',b-a'。。表示a取了0,b就不能取0,只能取1.

c==1时,a-b,b-a,a'-b',b'-a',表示a取了0,另一个也只能取0,取1同理。。

c==2时,a'-b,b'-a,表示a取了1,b就不能取1,只能取0.。

然后二分用多少组a,b,c就可以了。。。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>
using namespace std;
const int MAXN=410;
const int MAXE=40010;
int head[MAXN],size;
int a[10010],b[10010],c[10010],n,m;
struct EDGE
{
    int v,next;
}edge[MAXE];
int sccno[MAXN],low[MAXN],pre[MAXN],dfs_clock,sc_cnt;
stack<int> S;
void init()
{
    memset(head,-1,sizeof(head));
    memset(sccno,0,sizeof(sccno));
    memset(pre,0,sizeof(pre));
    dfs_clock=sc_cnt=size=0;
}
void add_edge(int u,int v)
{
    edge[size].v=v;
    edge[size].next=head[u];
    head[u]=size++;
}
void tarjan(int u)
{
    pre[u]=low[u]=++dfs_clock;
    S.push(u);
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(!pre[v])
        {
            tarjan(v);
            low[u]=min(low[u],low[v]);
        }
        else if(!sccno[v])
            low[u]=min(low[u],pre[v]);
    }
    if(pre[u]==low[u])
    {
        sc_cnt++;
        while(1)
        {
            int x=S.top();
            S.pop();
            sccno[x]=sc_cnt;
            if(u==x)
                break;
        }
    }
}
void build(int mid)
{
    init();
    for(int i=0;i<mid;i++)
    {
        if(c[i]==0)
        {
            add_edge(a[i]<<1,b[i]<<1|1);
            add_edge(b[i]<<1,a[i]<<1|1);
        }
        else if(c[i]==1)
        {
            add_edge(a[i]<<1,b[i]<<1);
            add_edge(b[i]<<1,a[i]<<1);
            add_edge(a[i]<<1|1,b[i]<<1|1);
            add_edge(b[i]<<1|1,a[i]<<1|1);
        }
        else
        {
            add_edge(a[i]<<1|1,b[i]<<1);
            add_edge(b[i]<<1|1,a[i]<<1);
        }
    }
}
bool test()
{
    int i;
    for(i=0;i<2*n;i++)
        if(!pre[i])
        tarjan(i);
    for(i=0;i<n;i++)
        if(sccno[i<<1]==sccno[i<<1|1])
        return 0;
    return 1;
}
int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&a[i],&b[i],&c[i]);
        }
        int l=0,r=m;
        int ans=-1;
        while(l<=r)
        {
            int mid=(l+r)>>1;
            build(mid);
            if(test())
            {
                ans=mid;
                l=mid+1;
            }
            else
                r=mid-1;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值