HDU4861 Couple doubi

Couple doubi


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 428 Accepted Submission(s): 328


Problem Description
DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.


Input
Multiply Test Cases.
In the first line there are two Integers k and p(1<k,p<2^31).


Output
For each line, output an integer, as described above.


Sample Input
2 3
20 3


Sample Output
YES
NO


Author
FZU

题意:有k个球,两个人去取,每个球有个价值,谁取到最后得到的价值最大就赢,每个就得价值有个公式算。

分析:官方题解有正确解法,当初是写了个暴力程序,然后看出了规律,就做出来了

#include<cstdio>
using namespace std;
int main()
{
    int n,p;
    while(scanf("%d%d",&n,&p)==2)
    {
        n=n/(p-1);
        if(n&1)
        {
            printf("YES\n");
        }
        else
            printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值