POJ2689 Prime Distance

Prime Distance

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12562 Accepted: 3354
Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).
Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.
Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.
Sample Input

2 17
14 17
Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.
Source

Waterloo local 1998.10.17

题意:求一个区间内两个相邻的素数之差最大的和最小的两个数。。

两次筛选,l,u的范围是2^31,他们两之差最大为1e6,对于所有合数,2^31里面肯定由2^16里的素数组成,所以先筛选出2^16里面的素数,然后将区间转化,                                a=(l-1)/prime[i]+1,b=u/prime[i],这个区间内的都是合数,然后标记就是,数组大小的话都减l就行,这个数组大小1e6.。。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int MAXN=50010;
const int MAXM=1000010;
int prime[MAXN],vis[MAXN],isprime[MAXM],p;
void isp()
{
    memset(vis,0,sizeof(vis));
    int i,j,m=(int)sqrt(MAXN+0.5);
    p=0;
    for(i=2;i<=m;i++)
    {
        if(!vis[i])
        {
            for(j=i*i;j<MAXN;j+=i)
                vis[j]=1;
        }
    }
    for(i=2;i<MAXN;i++)
        if(!vis[i])
        prime[p++]=i;
}
int main()
{
    int l,u,i,j;
    isp();
    while(scanf("%d%d",&l,&u)==2)
    {
        if(l==1)
            l=2;
        memset(isprime,0,sizeof(isprime));
        for(i=0;i<p&&prime[i]*prime[i]<=u;i++)
        {
            int a=(l-1)/prime[i]+1;
            int b=u/prime[i];
            for(j=a;j<=b;j++)
                if(j>1)
                isprime[j*prime[i]-l]=1;
        }
        int mmax=-1,mmin=1<<30,temp=-1,x1,x2,y1,y2;
        for(i=0;i<=u-l;i++)
        {
            if(!isprime[i])
            {
                if(temp==-1)
                {
                    temp=i;
                    continue;
                }
                if(i-temp>mmax)
                {
                    mmax=i-temp;
                    x1=temp;
                    y1=i;
                }
                if(i-temp<mmin)
                {
                    mmin=i-temp;
                    x2=temp;
                    y2=i;
                }
                temp=i;
            }
        }
        if(mmax==-1)
            printf("There are no adjacent primes.\n");
        else
            printf("%d,%d are closest, %d,%d are most distant.\n",x2+l,y2+l,x1+l,y1+l);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值