The Triangle POJ - 1163

The Triangle POJ - 1163

题目描述

        7
      3   8
    8   1   0
  2   7   4   4
4   5   2   6   5

    (Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30

大致题意
就是给你一个金字塔型的数列,然后你从最上层走到最下层,向左或者向右走到下一层,将经过的每个数字加起来,求最大的和。

思路
简单的dp,下一层的每个位置都可由其上一层的两个位置走到,选择其中的最大值,然后求最下层的每个位置所得到的值中的最大值。

代码如下

#include <iostream> 
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <list>
#define rep(i,m,n) for(i=m;i<=n;i++)
#define rsp(it,s) for(set<int>::iterator it=s.begin();it!=s.end();it++)
const int inf_int = 2e9;
const long long inf_ll = 2e18;
#define inf_add 0x3f3f3f3f
#define mod 1000000007
#define vi vector<int>
#define pb push_back
#define mp make_pair
#define fi first
#define se second
#define pi acos(-1.0)
#define pii pair<int,int>
#define Lson L, mid, rt<<1
#define Rson mid+1, R, rt<<1|1
const int maxn=5e2+10;
using namespace std;

int max(int x,int y)  // 比较两个数的值返回最大值
{
    return x>y?x:y;
}
int main()
{
     int  shu[105][105],f[105][105]; 
     int n,jieguo=0;
     memset(f,0,sizeof(f));       //f数组初始化
      cin>>n;
      for(int i=1;i<=n;i++)
      for(int j=1;j<=i;j++)
      cin>>shu[i][j];            
      for(int i=1;i<=n;i++)
      for(int j=1;j<=i;j++)
      {
        if(i==1) 
        f[i][j]=shu[i][j];      //第一层的数值
        else if(j==1) f[i][j]=f[i-1][j]+shu[i][j];   //最左边的情况
        else if(j==i) f[i][j]=f[i-1][j-1]+shu[i][j];  //最右边的情况
        else 
        f[i][j]=max(f[i-1][j],f[i-1][j-1])+shu[i][j];  // 中间的情况
      }
      for(int i=1;i<=n;i++)    // 求最底层的最大值
      jieguo=max(jieguo,f[n][i]);
      cout<<jieguo<<endl;         
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值