The Triangle(POJ - 1163)

 

The Triangle

 POJ - 1163 

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

思路1:

  • dfs+记忆型递归

AcCode:

import static java.lang.Math.max;

import java.util.Scanner;

public class Main{
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int N = in.nextInt();
		int[][] nums = new int[N][N];
		for (int i = 0; i < nums.length; i++) {
			for (int j = 0; j <= i; j++) {
				nums[i][j] = in.nextInt();
			}
		}
		cache = new int[N][N];
		for (int i = 0; i < nums.length; i++) {
			for (int j = 0; j <=i; j++) {
				cache[i][j] = -1;
			}
		}
		int res = dfs(nums,0,0);
		System.out.println(res);
	}
	static int[][] cache = null;
	private static int dfs(int[][] nums, int i, int j) {
		if(cache[i][j]>=0) {
			return cache[i][j];
		}
		int leftDown = 0;
		int rightDown = 0;
		//往左下走
		if(i+1<nums.length) {
			leftDown = dfs(nums, i+1, j);
		}
		//往右下走
		if(i+1<nums.length && j+1<nums[i+1].length) {
			rightDown = dfs(nums, i+1, j+1);
		}
		cache[i][j] = max(nums[i][j]+leftDown, nums[i][j]+rightDown);
		return cache[i][j];
	}
}

 思路2:

  • 使用二维数组自底向上dp
  • dp[i][j] = nums[i][j] + max(dp[i+1][j],dp[i+1][j+1])

AcCode:

import static java.lang.Math.max;

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int N = in.nextInt();
		int[][] nums = new int[N][N];
		for (int i = 0; i < nums.length; i++) {
			for (int j = 0; j <=i; j++) {
				nums[i][j] = in.nextInt();
			}
		}
		int res = dp(nums);
		System.out.println(res);
	}

	private static int dp(int[][] nums) {
		int[][] dp = new int[nums.length][nums.length];
		//初始化
		for (int j = 0; j < dp[nums.length-1].length; j++) {
			dp[nums.length-1][j] = nums[nums.length-1][j];
		}
		for (int i = nums.length-2; i >=0 ; i--) {
			for (int j = 0; j <=i; j++) {
				dp[i][j] = nums[i][j]+max(dp[i+1][j],dp[i+1][j+1]);
			}
		}
		return dp[0][0];
	}
}

思路3:

  •  跟上面dp的思路一样,但是存值的时候使用一维的滚动数组更节约内存
  • dp[j] = nums[i][j]+max(dp[j],dp[j+1])
import static java.lang.Math.max;

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int N = in.nextInt();
		int[][] nums = new int[N][N];
		for (int i = 0; i < nums.length; i++) {
			for (int j = 0; j <=i; j++) {
				nums[i][j] = in.nextInt();
			}
		}
		//二维dp
//		int res = dp(nums);
//		System.out.println(res);
		//滚动数组-一维dp
		int res2 = dp2(nums);
		System.out.println(res2);
	}
	
	

	private static int dp2(int[][] nums) {
		int[] dp = new int[nums[nums.length-1].length];
		for (int j = 0; j < dp.length; j++) {
			dp[j] = nums[nums.length-1][j];
		}
		
		for (int i = nums.length-2; i >=0; i--) {
			for (int j = 0; j <=i; j++) {
				dp[j] = nums[i][j]+max(dp[j], dp[j+1]);
			}
		}

		return dp[0];
	}



	private static int dp(int[][] nums) {
		int[][] dp = new int[nums.length][nums.length];
		//初始化
		for (int j = 0; j < dp[nums.length-1].length; j++) {
			dp[nums.length-1][j] = nums[nums.length-1][j];
		}
		for (int i = nums.length-2; i >=0 ; i--) {
			for (int j = 0; j <=i; j++) {
				dp[i][j] = nums[i][j]+max(dp[i+1][j],dp[i+1][j+1]);
			}
		}
		return dp[0][0];
	}
}

 

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip 【备注】 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用!有问题请及时沟通交流。 2、适用人群:计算机相关专业(如计科、信息安全、数据科学与大数据技术、人工智能、通信、物联网、自动化、电子信息等)在校学生、专业老师或者企业员工下载使用。 3、用途:项目具有较高的学习借鉴价值,不仅适用于小白学习入门进阶。也可作为毕设项目、课程设计、大作业、初期项目立项演示等。 4、如果基础还行,或热爱钻研,亦可在此项目代码基础上进行修改添加,实现其他不同功能。 欢迎下载!欢迎交流学习!不清楚的可以私信问我! 毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值