poj 2236 Wireless Network

题目描述
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS

大致题意:首先输入n和d,n表示有n台编号1~n的电脑,d表示两台能联系上的电脑的最大距离。接下来n行每行输入两个数x,y表示编号1~n的电脑的坐标。接下来有一系列的两种操作,当输入为O x,x为一个整数时,表示修复编号为x的电脑,当输入为S x y,x,y分别表示两个整数,表示查询编号x和y的两台电脑能否联系上,如果能则输出SUCCESS否则输出FAIL。 一开始所有的电脑都是坏的,两台好的电脑可以通过他们所能联系上的好电脑进行联系。

思路:简单的并查集,每次修复一个电脑,就遍历其与其他修好的电脑是否在同一个集合中,如果不是的话再判断他们之间的距离是否小于等于d,如果是则将其加入。然后查询的时候判断一下两个电脑是否有在同一集合中即可。
(注意操作时输入的字母O而不是数字0。。。。。)

代码如下

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include<string>
#include<queue>
#include<map>

using namespace std;
int pre[1005];
int vis[1005];//判断是否已经修好
int w[1005][2];
int N,d;
int find(int x)
{
    int r=x;
   while (pre[r]!=r)
   r=pre[r];
   int i=x; int j;
   while(i!=r)
   {
       j=pre[i];
       pre[i]=r;
       i=j;
   }
   return r;
}
int main()
{
    for(int i=0;i<1005;i++)
    pre[i]=i;
    memset(vis,0,sizeof(vis));

    cin>>N>>d; 
      for(int i=1;i<=N;i++)
      cin>>w[i][0]>>w[i][1];
      getchar();
      char c;
      while(cin>>c)
      {
        if(c=='O')
        {
            int x;
            cin>>x;
            vis[x]=1;
            for(int i=1;i<=N;i++)
            {
                if(i!=x&&vis[i]==1)
                {
                    int dx=w[x][0]-w[i][0];
                    int dy=w[x][1]-w[i][1];
                    dx*=dx;
                    dy*=dy;
                    if(dx+dy<=d*d)
                    {
                        int f1=find(i);
                        int f2=find(x);
                        if(f1!=f2)
                        {
                            pre[f2]=f1;
                          }
                      }
                  }
              }
          }
          else 
          {
            int x,y;
            cin>>x>>y;
            getchar();
            int f1=find(x);
            int f2=find(y);
            if(f1==f2)
            cout<<"SUCCESS"<<endl;
            else 
            cout<<"FAIL"<<endl;
          }
      }

   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园建设方案旨在通过融合先进技术,如物联网、大数据、人工智能等,实现校园的智能化管理与服务。政策的推动和技术的成熟为智慧校园的发展提供了基础。该方案强调了数据的重要性,提出通过数据的整合、开放和共享,构建产学研资用联动的服务体系,以促进校园的精细化治理。 智慧校园的核心建设任务包括数据标准体系和应用标准体系的建设,以及信息化安全与等级保护的实施。方案提出了一站式服务大厅和移动校园的概念,通过整合校内外资源,实现资源共享平台和产教融合就业平台的建设。此外,校园大脑的构建是实现智慧校园的关键,它涉及到数据中心化、数据资产化和数据业务化,以数据驱动业务自动化和智能化。 技术应用方面,方案提出了物联网平台、5G网络、人工智能平台等新技术的融合应用,以打造多场景融合的智慧校园大脑。这包括智慧教室、智慧实验室、智慧图书馆、智慧党建等多领域的智能化应用,旨在提升教学、科研、管理和服务的效率和质量。 在实施层面,智慧校园建设需要统筹规划和分步实施,确保项目的可行性和有效性。方案提出了主题梳理、场景梳理和数据梳理的方法,以及现有技术支持和项目分级的考虑,以指导智慧校园的建设。 最后,智慧校园建设的成功依赖于开放、协同和融合的组织建设。通过战略咨询、分步实施、生态建设和短板补充,可以构建符合学校特色的生态链,实现智慧校园的长远发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值