hdu 4280 Island Transport

Problem Description
  In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships.
  You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
  The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.

Input
  The first line contains one integer T (1<=T<=20), the number of test cases.
  Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
  Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
  Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
  It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.

Output
  For each test case, output an integer in one line, the transport capacity.

Sample Input
2
5 7
3 3
3 0
3 1
0 0
4 5
1 3 3
2 3 4
2 4 3
1 5 6
4 5 3
1 4 4
3 4 2
6 7
-1 -1
0 1
0 2
1 0
1 1
2 3
1 2 1
2 3 6
4 5 5
5 6 3
1 4 6
2 5 5
3 6 4

Sample Output
9
6

大致题意:有n个岛, m条路。每条路都有一个容量,代表一小时内能运送的游客量。现在求从最西边的岛到最东边的岛在一小时内最多能运送多少的游客。

思路:裸最大流,套板子
代码如下

#include<stdio.h>
#include<string.h>
#include<stdio.h>
#include<cstdio>
#include<iostream>
using namespace std;

const int MAXN=100010;//点数最大值
const int MAXM=400010;//边数最大值
const int INF=0x3f3f3f3f;


struct Node
{
    int from,to,next;
    int cap;
 } edge[MAXM];

 int tol;
 int head[MAXN];
 int dep[MAXN];
 int gap[MAXN];//gap[x]=y:说明残留网络中dep[i]==x的个数为y

 int n;//n是总的点的个数,包括源点和汇点

 void init()
 {
    tol=0;
    memset(head,-1,sizeof(head));
  } 

  void addedge(int u,int v,int w)
  {
    edge[tol].from=u;
    edge[tol].to=v;
    edge[tol].cap=w;
    edge[tol].next=head[u];
    head[u]=tol++;

    edge[tol].from=v;
    edge[tol].to=u;
    edge[tol].cap=0;
    edge[tol].next=head[v];
    head[v]=tol++;
  }

  void BFS(int start,int end)
  {
    memset(dep,-1,sizeof(dep));
    memset(gap,0,sizeof(gap));
    gap[0]=1;
    int que[MAXN];
    int front,rear;
    front=rear=0;
    dep[end]=0;
    que[rear++]=end;
    while(front!=rear)
    {
        int u=que[front++];
        if(front==MAXN) front=0;
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].to;
            if(dep[v]!=-1)   continue;
            que[rear++]=v;
            if(rear==MAXN) rear=0;
            dep[v]=dep[u]+1;
            ++gap[dep[v]];
          }
      }
  }

  int SAP(int start,int end)
  {
    int res=0;
    BFS(start,end);
    int cur[MAXN];
    int S[MAXN];
    int top=0;

    memcpy(cur,head,sizeof(head));
    int u=start;
    int i;
    while(dep[start]<n)
    {
        if(u==end)
        {
            int temp=INF;
            int inser;
            for(i=0;i<top;i++)
            if(temp>edge[S[i]].cap)
            {
                temp=edge[S[i]].cap;
                inser=i;
            }
            for(i=0;i<top;i++)
            {
                edge[S[i]].cap-=temp;
                edge[S[i]^1].cap+=temp;
              }  
            res+=temp;
            top=inser;
            u=edge[S[top]].from;  
        }
         if(u!=end&&gap[dep[u]-1]==0)//出现断层,无增广路
          break;
        for(i=cur[u];i!=-1;i=edge[i].next)
           if(edge[i].cap!=0&&dep[u]==dep[edge[i].to]+1)
             break;
        if(i!=-1)
        {
            cur[u]=i;
            S[top++]=i;
            u=edge[i].to;
        }
        else 
        {
            int min=n;
            for(i=head[u];i!=-1;i=edge[i].next)
            {
                if(edge[i].cap==0) continue;
                if(min>dep[edge[i].to])
                {
                    min=dep[edge[i].to];
                    cur[u]=i;
                }
            }
            --gap[dep[u]];
            dep[u]=min+1;
            ++gap[dep[u]];
            if(u!=start)
            u=edge[S[--top]].from;
        }

      }
      return res;
  }

  int main()
  {
    int start,end;
    int m;
    int u,v,z;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        init();
        scanf("%d%d",&n,&m);
        int minx=10000000;
        int maxx=-10000000;
        int x,y;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&x,&y);
            if(minx>x)
            {
                minx=x;
                start=i;
            }
            if(maxx<x)
            {
                maxx=x;
                end=i;
            }
        }
        while(m--)
        {
            scanf("%d%d%d",&u,&v,&z);
            addedge(u,v,z);
            addedge(v,u,z);
        }
        int ans=SAP(start,end);
        printf("%d\n",ans);
      }
      return 0;
  }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值