Visible Lattice Points POJ - 3090 (欧拉函数筛)

A lattice point (x, y) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (x, y) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (x, y) with 0 ≤ x, y ≤ 5 with lines from the origin to the visible points.
这里写图片描述
Write a program which, given a value for the size, N, computes the number of visible points (x, y) with 0 ≤ x, y ≤ N.

Input
The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output
For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input
4
2
4
5
231
Sample Output
1 2 5
2 4 13
3 5 21
4 231 32549

大致题意:有一个n*n的二维格点,问在原点(0,0)处能看到多少个格点?

思路:可以推出当且仅当格点的坐标(x,y),满足gcd(x,y)==1时,该点才能被看到。因为上下是对称的,所以我们只用先考虑一部分的情况,然后将答案乘上2。考虑上半部分,即x < y。显然想要每次暴力求出有多少个gcd(x,y)=1,是会超时的,所以我们可以用欧拉函数筛预先求出前1000的欧拉值,(i的欧拉值表示有多少个数小于i且与其互质)然后每次询问,我们就将1到n的欧拉值相加,最后将结果乘2再加1即可。

代码如下

#include <iostream> 
#include <cstring>
#include <cstdio>
using namespace std; 
#define LL long long 
const int M=1005;

int p[M],phi[M];
bool vis[M];
int p_num=0;
void prim()
{
    for(int i=2;i<=1000;i++)
    {
        if(!vis[i])
        {
            p[p_num++]=i;
            phi[i]=i-1;
        }
        for(int j=0;j<p_num&&p[j]*i<=1000;j++)
        {
            vis[p[j]*i]=1;
            if(i%p[j]==0)
            {
                phi[i*p[j]]=phi[i]*p[j];
                break;
            }
            else 
            phi[i*p[j]]=phi[i]*(p[j]-1);
        }
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    prim();
    phi[1]=1;
    for(int cas=1;cas<=T;cas++)
    {
        int n;
        scanf("%d",&n);
        int sum=0;
        for(int i=1;i<=n;i++)
            sum+=phi[i];
        printf("%d %d %d\n",cas,n,2*sum+1);
    }
    return 0; 
} 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值