poj3090(拿ETH筛跑欧拉函数)

9 篇文章 1 订阅

Visible Lattice Points

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9189 Accepted: 5602

Description

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.

Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

Source

Greater New York 2006

证明详见lyd blog

/* 利用欧拉函数性质进行优化
假设素数p能整除n,那么
如果p还能整除n / p, PHI(n) = PHI(n / p) * p;
如果p不能整除n / p, PHI(n) = PHI(n / p) * (p - 1);
*/
#include<iostream>
#include<algorithm>
using namespace std;
int v[1010], prime[1010], phi[1010], sum[1010], m, t, n;

void euler(int n) {
	memset(v, 0, sizeof(v)); // 最小质因子
	m = 0; // 质数数量
	for (int i = 2; i <= n; i++) {
		if (v[i] == 0) { // i是质数
			v[i] = i, prime[++m] = i;
			phi[i] = i - 1;
		}
		// 给当前的数i乘上一个质因子
		for (int j = 1; j <= m; j++) {
			// i有比prime[j]更小的质因子,或者超出n的范围
			if (prime[j] > v[i] || prime[j] > n / i) break;
			// prime[j]是合数i*prime[j]的最小质因子
			v[i*prime[j]] = prime[j];
			phi[i*prime[j]] = phi[i] * (i%prime[j] ? prime[j]-1 : prime[j]);
		}
	}
}

int main() {
	euler(1000);
	for (int i = 2; i <= 1000; i++)
		sum[i] = sum[i - 1] + phi[i];
	cin >> t;
	for (int i = 1; i <= t; i++){
		scanf("%d", &n);
		printf("%d %d %d\n", i, n, sum[n] * 2 + 3);
	}
}

 

//优化前裸跑ETH筛
#include<bits/stdc++.h>
int f[1010],n,t,i,j;
int main()
{
	n=1000;
	for(i=1;i<=n;i++) f[i]=i;
	for(i=2;i<=n;i++)
		if(f[i]==i)
			for(j=i;j<=n;j+=i)
				f[j]=f[j]/i*(i-1);
	f[1]=0;
	for(i=2;i<=n;i++) f[i]+=f[i-1];
	scanf("%d",&t);
	for(i=1;i<=t;i++)
	{
		scanf("%d",&n);
		printf("%d %d %d\n",i,n,f[n]*2+3);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值