poj 3468 A Simple Problem with Integers(线段树区间修改+区间求和)

Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output

4
55
9
15
Hint

The sums may exceed the range of 32-bit integers.

代码如下

#include<iostream>
#include <cstdio>  
#include <algorithm>    
#define lson l , m , rt << 1  
#define rson m + 1 , r , rt << 1 | 1  
#define LL long long  
using namespace std;
const int maxn =100005;  
LL lazy[maxn<<2];  
LL sum[maxn<<2]; 
int A[maxn]; 

void PushUp(int rt) 
{  
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];  
}  
void PushDown(int rt,int m)
{  
    if(lazy[rt])
    {  
        lazy[rt<<1]+=lazy[rt];  
        lazy[rt<<1|1]+=lazy[rt];  
        sum[rt<<1]+=lazy[rt]*(m-(m>>1));  
        sum[rt<<1|1]+=lazy[rt]*(m>>1);  
        lazy[rt]=0;  
    }  
}  

void build(int l,int r,int rt) 
{  
    lazy[rt] = 0;  
    if(l==r) 
    {  
        //scanf("%lld",&sum[rt]); 
        sum[rt]=A[l]; 
        return ;  
    }  
    int m=(l+r)>>1;  
    build(lson);  
    build(rson);  
    PushUp(rt);  
}  

void update(int L,int R,int c,int l,int r,int rt) 
{  
    if (L<=l&&r<=R) 
    {  
        lazy[rt]+=c;

        sum[rt]+=(LL)c*(r-l+1);  

        return ;  
    }  
    PushDown(rt,r-l+1);  
    int m=(l+r)>>1;  
    if (L<=m) update(L,R,c,lson);  
    if (m<R) update(L,R,c,rson);  
    PushUp(rt);  
}  

LL query(int L,int R,int l,int r,int rt) 
{  
    if (L<=l&&r<=R) 
    {  
        return sum[rt];  
    }  
    PushDown(rt,r-l+1);  

    int m=(l+r)>>1;  
    LL ret = 0;  
    if (L<=m) ret+=query(L,R,lson);  
    if (m<R) ret+=query(L,R,rson);  
    return ret;  
}  
int main() 
{  
    int n,q;  

    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;i++)
        scanf("%d",&A[i]);

    build(1,n,1);  
    while(q--) 
    {  
        getchar();
        char ch;
        scanf("%c",&ch);
        if(ch=='Q')
        {
            int x,y;
            scanf("%d %d",&x,&y);
            printf("%lld\n",query(x,y,1,n,1));

        }
        else 
        {
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            update(x,y,z,1,n,1); 
        }
    }  
    return 0;  
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值