Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15
大致题意:让你找出和最大的子矩阵。
思路:枚举最大子矩阵的上下界,然后将每一列的值相加存到一个数组中,然后问题就转化成了求最大连续子段和时间复杂度为O(n),总的时间复杂度为n^3
代码如下
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int a[105][105];
int b[105];
int main()
{
std::ios::sync_with_stdio(false);
int n;
while(cin>>n)
{
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
cin>>a[i][j];
int ans=-1e8;
for(int i=1;i<=n;i++)
{
memset(b,0,sizeof(b));
for(int j=i;j<=n;j++)
{
for(int k=1;k<=n;k++)
b[k]+=a[j][k];
int sum=0;
for(int k=1;k<=n;k++)
{
if(sum<0)
sum=b[k];
else
sum+=b[k];
ans=max(ans,sum);
}
}
}
cout<<ans<<endl;
}
return 0;
}