POJ1654 Area(多边形面积,叉积求三角形面积)

Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.
Sample Input

4
5
825
6725
6244865
Sample Output

0
0
0.5
2

大致题意:一开始有个人在点(0,0)位置,然后告诉你这个人每次走一步的方向,共8个方向,最后会回到原点,问所走路径连起来的多边形的面积是多少。

思路:每次将上一步所在的点和现在所在的点与原点相连所构成的两个向量,它们的叉积除以2即这三个点形成的三角形的面积,最后的多边形的面积即这些小三角形面积的和。
注意:double精度不够,然后最后的结果不是整数就是整数加0.5,所以我们可以用longlong,最后判断下是否能被2整除。

代码如下

#include<iostream>
#include<set>
#include<vector>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
typedef long long ll;
const double eps=1e-8;
int dx[10] = { 0,-1,0,1,-1,0,1,-1,0,1 };    //记录每种操作走的方向
int dy[10] = { 0,-1,-1,-1,0,0,0,1,1,1 };
int dcmp(double x) {
    if(fabs(x)<eps) return 0;
    return x<0?-1:1;
}
struct Point {
    int x,y;
    Point() {}
    Point(int  _x,int _y) {
        x=_x;
        y=_y;
    }
    Point operator-(const Point &b) const {
        return Point(x-b.x,y-b.y);
    }
    int operator *(const Point &b)const {
        return x*b.x + y*b.y;
    }
    int operator ^(const Point &b)const {
        return x*b.y - y*b.x;
    }
};

int xmult(Point p0,Point p1,Point p2) {
    return (p1-p0)^(p2-p0);
}

const int maxn=1000010;
char str[maxn];
int main() 
{
    ll ans;
    int T;
    scanf("%d",&T);
    Point p1,p2; 
    Point p;//原点 
    p.x=p.y=0;
    while(T--)
    {
        p1.x=0;
        p1.y=0;
        ans=0;
        scanf("%s",str);
        int len=strlen(str);
        for(int i=0;i<len-1;i++)
        {
            p2.x=p1.x+dx[str[i]-'0'];
            p2.y=p1.y+dy[str[i]-'0'];

            ans+=xmult(p,p1,p2);

            p1.x=p2.x;//更新上一步的坐标 
            p1.y=p2.y;
        }
        if(ans<0) ans=-ans;//可能是负数
        if(ans%2==0)    printf("%lld\n",ans/2);
        else printf("%lld.5\n",(ans-1)/2);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值