A Dangerous Maze LightOJ - 1027 (概率期望)

You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.

If you choose the ith door, it can either take you back to the same position where you begun in xi minutes, or can take you out of the maze after xi minutes. If you come back to the same position, you can’t remember anything. So, every time you come to the beginning position, you have no past experience.

Now you want to find the expected time to get out of the maze.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains n space separated integers. If the ith integer (xi) is positive, you can assume that the ith door will take you out of maze after xi minutes. If it’s negative, then the ith door will take you back to the beginning position after abs(xi) minutes. You can safely assume that 1 ≤ abs(xi) ≤ 10000.

Output
For each case, print the case number and the expected time to get out of the maze. If it’s impossible to get out of the maze, print ‘inf’. Print the result in p/q format. Where p is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.

Sample Input
3

1
1

2
-10 -3

3
3 -6 -9
Sample Output
Case 1: 1/1
Case 2: inf
Case 3: 18/1

大致题意:有n个门,你所选取的每个门的概率都一样,每个门都有一个值,如果值xi为正,那么经过xi的时间你就能打开门出去,如果xi值为负,那么经过xi时间你依旧会停留在原地,每次你都会忘记自己所选的上一个门。问出去的时间期望是多少,如果出不去的话输出inf。

思路:假设时间期望为t,负值的门的个数为m,那么t=1/n(X1+X2+…+Xn-m)+1/n(abs(x1+x2+…+xm)+m*t),解得t=(X1+X2+…+Xn-m+abs(x1+x2+…+xm))/(n-m)

代码如下

#include<iostream>
#include<set>
#include<vector>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
typedef long long ll;
int gcd(int a,int b)
{
    if(b==0) return a;
    else return gcd(b,a%b);
}
int main()
{
    int T;
    scanf("%d",&T);
    for(int cas=1;cas<=T;cas++)
    {
        int n;
        int cnt=0;
        int sum=0;
        int x;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            if(x<0) 
            {
                cnt++;
                x=-x;
            }
            sum+=x;
        }
        printf("Case %d: ",cas);
        if(cnt==n)
            printf("inf\n");
        else 
        {
            int t=gcd(n-cnt,sum);
            printf("%d/%d\n",sum/t,(n-cnt)/t);
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值