Just another Robbery LightOJ - 1079 (概率dp,01背包)

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probability P of getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output
For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
Case 1: 2
Case 2: 4
Case 3: 6
Hint
For the first case, if he wants to rob bank 1 and 2, then the probability of getting caught is 0.02 + (1 - 0.02) * .03 = 0.0494 which is greater than the given probability (0.04). That’s why he has only option, just to rob rank 2.

大致题意:你打算去偷n个银行,每个银行有一个价值和一个被抓的概率,问在被抓概率小于P的情况下所能得到的最大的价值。

思路:很容易可以看出是个01背包的模型,如果直接去求偷取某些银行后被抓的概率的话会有点麻烦,但是逃脱(即不被抓)的概率就很好求了,每个银行的逃脱概率即1减去被抓概率,然后直接将所要偷取的银行的逃脱概率相乘即可。假设dp[i]表示偷取总价值为i时的最大逃脱概率,答案即为求最大的i满足dp[i]大于1-P,假设sum为所有银行的总价值,将i的值从sum到0遍历一遍判断下即可。

代码如下

#include<bits/stdc++.h>
const int N=100;
const double eps=1e-6;
#define LL long long int
using namespace std;
double dp[10015];
struct node
{
    int val;
    double s;   
};
node a[105]; 
int main()
{
    int T;
    scanf("%d",&T);
    for(int cas=1;cas<=T;cas++)
    {
        int n;
        double P;
        int sum=0;
        memset(dp,0,sizeof(dp));

        scanf("%lf%d",&P,&n);
        P=1-P;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%lf",&a[i].val,&a[i].s);
            a[i].s=1.0-a[i].s;
            sum+=a[i].val;
        }

        dp[0]=1;
        for(int i=1;i<=n;i++)//01背包方程
        for(int j=sum;j>=a[i].val;j--)
        {   
            dp[j]=max(dp[j],dp[j-a[i].val]*a[i].s);
        }
        int ans=0;
        for(int i=sum;i>=0;i--)
        {
            if(dp[i]-P>eps)
            {
                ans=i;
                break;
            }
        }
        printf("Case %d: %d\n",cas,ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值