2017 ACM-ICPC 亚洲区(南宁赛区)网络赛 M Frequent Subsets Problem

The frequent subset problem is defined as follows. Suppose UU={1, 2,\ldots,N} is the universe, and S_{1}S1S_{2}S2,\ldots,S_{M}SMare MM sets over UU. Given a positive constant \alphaα0<\alpha \leq 10<α1, a subset BB (B \neq 0B0) is α-frequent if it is contained in at least \alpha MαM sets of S_{1}S1S_{2}S2,\ldots,S_{M}SM, i.e. \left | \left \{ i:B\subseteq S_{i} \right \} \right | \geq \alpha M{i:BSi}αM. The frequent subset problem is to find all the subsets that are α-frequent. For example, let U=\{1, 2,3,4,5\}U={1,2,3,4,5}M=3M=3\alpha =0.5α=0.5, and S_{1}=\{1, 5\}S1={1,5}S_{2}=\{1,2,5\}S2={1,2,5}S_{3}=\{1,3,4\}S3={1,3,4}. Then there are 33 α-frequent subsets of UU, which are \{1\}{1},\{5\}{5} and \{1,5\}{1,5}.

Input Format

The first line contains two numbers NN and \alphaα, where NN is a positive integers, and \alphaα is a floating-point number between 0 and 1. Each of the subsequent lines contains a set which consists of a sequence of positive integers separated by blanks, i.e., line i + 1i+1 contains S_{i}Si1 \le i \le M1iM . Your program should be able to handle NN up to 2020 and MM up to 5050.

Output Format

The number of \alphaα-frequent subsets.

样例输入
15 0.4
1 8 14 4 13 2
3 7 11 6
10 8 4 2
9 3 12 7 15 2
8 3 2 4 5
样例输出
11
题目来源

2017 ACM-ICPC 亚洲区(南宁赛区)网络赛


题意:先给你两个数 n 和 aa,n 表示一个有 n 个元素的集合 U = {1,2,......,n},而 aa 则表示在接下来的 M 个子集合 Si(i = 1, 2, ..., M)中,能否从中抽出一组数,使得这组数在这 M 个集合中存在的个数 >= aa * M,然后接下来有 M 行输入,表示子集合 S,输入完毕。要求你输出一共有多少组数符合上述条件。


题解:这道题就是典型的状压dp,但一开始我没想到这一点,一直tle。


直接上代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
#define mem(a, b) memset(a, b, sizeof(a))
using namespace std;
typedef long long LL;
///o(っ。Д。)っ AC万岁!!!!!!!!!!!!!!
const int maxn = 100;
int sum[maxn] = {};
int main()
{
    int n;
    float aa;
    while(scanf("%d %f", &n, &aa) != EOF)
    {
        mem(sum, 0);
        int cnt = 1, book;
        char ch;
        while(scanf("%d%c", &book, &ch) != EOF)
        {
            sum[cnt] += (1 << book);
            if(ch == '\n') cnt++;
        }
        cnt--;
        int jud = (cnt * aa) - (int)(cnt * aa) >= 0.000001 ? (int)(cnt * aa + 1) : (int)(cnt * aa);
        ///不是(int)(cnt * aa),因为会有像6.04这样的情况
        ///也可以这样:int jud = ceil(cnt * aa);
        int ans = 0, maxx = 1 << n, counter = 0;
        for(int i = 1; i <= maxx; i++)
        {
            ans = 0;
            for(int j = 1; j <= cnt; j++)
            {
                if((i & sum[j]) == i)
                {
                    ans++;
                    /*if(ans >= jud)
                    {
                        printf("i = %d  sum[%d] = %d\n", i, j, sum[j]);
                        for(int k = 1; k <= n; k++)
                        {
                            if((1 << k) & i) printf("%d ", k);
                        }
                        printf("\n");
                    }

                    */
                }
            }
            if(ans >= jud) counter++;
        }
        printf("%d\n", counter);
    }
    return 0;
}
/*


*/



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值