poj1740 A New Stone Game

http://www.elijahqi.win/2018/01/16/poj1740-a-new-stone-game/
Description
Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn.
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
2 1 4 2
1 2 4 2(move one stone to Pile 2)
1 1 5 2(move one stone to Pile 3)
1 1 4 3(move one stone to Pile 4)
0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
0 3 4 2(move two stones to Pile 2)
0 1 6 2(move two stones to Pile 3)
0 1 4 4(move two stones to Pile 4)
Alice always moves first. Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.

Input
The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100.
The last test case is followed by one zero.

Output
For each test case, if Alice win the game,output 1,otherwise output 0.

Sample Input

3
2 1 3
2
1 1
0

Sample Output

1
0

Source
LouTiancheng@POJ
题意:每次给定N堆石子 然后每次可以对n堆石子进行操作 至少必须扔掉一个 剩下的可以为所欲为 放到其他堆或者不动 但不允许新建一堆 首先可以知道假如只有两堆一样的石子那么后手模仿先手一定可以搞定先手必败与此同时可以得知 如果这现在的石子中有偶数个堆都相同 那么一定是先手必败对于奇数的情况我可以考虑我把最大的那个全部拿光用来补充其他使得出现偶数个堆相同那么后手必败了
具体证明可以参照这个巨佬的blog
http://blog.csdn.net/vicjiao/article/details/79075329 大意是搞一个数轴对于我最大的那个数肯定可以填上其他的数之间的空隙 对于偶数堆 但是 里面有一个奇数堆的我也可以是必胜的为什么如何决策我可以用最大的那个搬成和最小的一样多 然后再用差值补充其他的 凑出对手必败情况 就搞定了%%icefox 他好强啊带着我们搞ltc的题

#include<cstdio>
#include<cstring>
int n,cnt[110];
int main(){
    //freopen("poj1740.in","r",stdin);
    while(1){
        scanf("%d",&n);if (!n) return 0;memset(cnt,0,sizeof(cnt));
        for (int i=1;i<=n;++i) {int x=0;scanf("%d",&x);cnt[x]++;}bool flag=0;
        if (n&1) {puts("1");continue;}
        for (int i=1;i<=100;++i) if(cnt[i]&1) {puts("1");flag=1;break;}
        if (flag) continue;else puts("0");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值