POJ1740 A New Stone Game (博弈)

33 篇文章 1 订阅
24 篇文章 0 订阅

A New Stone Game
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6214 Accepted: 3394

Description

Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn. 
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones. 
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states. 
2 1 4 2 
1 2 4 2(move one stone to Pile 2) 
1 1 5 2(move one stone to Pile 3) 
1 1 4 3(move one stone to Pile 4) 
0 2 5 2(move one stone to Pile 2 and another one to Pile 3) 
0 2 4 3(move one stone to Pile 2 and another one to Pile 4) 
0 1 5 3(move one stone to Pile 3 and another one to Pile 4) 
0 3 4 2(move two stones to Pile 2) 
0 1 6 2(move two stones to Pile 3) 
0 1 4 4(move two stones to Pile 4) 
Alice always moves first. Suppose that both Alice and Bob do their best in the game. 
You are to write a program to determine who will finally win the game. 

Input

The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100. 
The last test case is followed by one zero. 

Output

For each test case, if Alice win the game,output 1,otherwise output 0. 

Sample Input

3
2 1 3
2
1 1
0

Sample Output

1
0

Source


题目链接:http://poj.org/problem?id=1740

【题意】有n堆石子,每次可以从某堆石子上至少取走一个,然后从该堆石子上任意移走x个(0<=x)去其他任意堆(可以同时移到多堆上)。

【思路】分析可得,当相同数目的石子堆都出现偶数次的时候,先手必败。再分析其他情况,当数目相等的石子堆出现不都是偶数次的时候,假设当前n为偶数,可以发现最大数和最小数之间的差比其他任意两两相邻(从小到大)的差的和都要大,故先手可以把该局面变成相同数目石子堆都出现偶数次的情况,因此先手必胜;奇数堆的时候分析相同。

【代码如下】

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int n,vis[110];

int main(){
    while(~scanf("%d",&n) && n){
       memset(vis,0,sizeof(vis));
       int ans = 0;
       int x;
       for(int i = 0; i < n; i ++){
            scanf("%d",&x);
            if(vis[x]) ans --;
            else ans ++;
            vis[x] = !vis[x];
       }
       if(ans) printf("1\n");
       else printf("0\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值