POJ 1068 Parencodings

Parencodings

Time Limit: 1000MS

Memory Limit: 10000K

Total Submissions: 27370

Accepted: 16089

Description

Let S = s1s2...s2n be a well-formed string of parentheses. S can be encoded in twodifferent ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of leftparentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say ain S, we associate an integer which is the number of right parentheses countingfrom the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 


        S              (((()()())))


        P-sequence         4 5 6666


        W-sequence         1 1 1456

 


Write a program to convert P-sequence of a well-formed string to the W-sequenceof the same string. 

Input

The first line ofthe input contains a single integer t (1 <= t <= 10), the number of testcases, followed by the input data for each test case. The first line of eachtest case is an integer n (1 <= n <= 20), and the second line is theP-sequence of a well-formed string. It contains n positive integers, separatedwith blanks, representing the P-sequence.

Output

The output fileconsists of exactly t lines corresponding to test cases. For each test case,the output line should contain n integers describing the W-sequence of thestring corresponding to its given P-sequence.

Sample Input

2

6

4 5 6 6 6 6

9

4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6

1 1 2 4 5 1 1 3 9

 

模拟方法,首先构造字符串:

int produceS(int n, int* Psequence, char* tmpc) {

       int k = 0;

       for (int i = 1; i <= n; i++) {

              for (int j = 0; j<Psequence[i] - Psequence[i - 1]; j++)

                     tmpc[k++] = '(';

              tmpc[k++] = ')';

       }

       return k;

}

 

然后使用堆统计匹配的括号:

void solve(char* tmpc, int length) {

       stack<char> cstack;

       for (int i = 0; i<length; i++) {

              if (tmpc[i] == '(') { cstack.push('('); continue; }

              int ans = 1;

              while(!cstack.empty() && cstack.top() != '(')

              {

                     ans +=cstack.top() - '0';

                     cstack.pop();

              }

              cstack.pop();

              cstack.push('0' + ans);

              cout << ans;

              string tmp = i != length - 1 ? " " : "";

              cout << tmp;

       }

       cout << endl;

}

 

 

完整代码如下:

#include <cstdio>

#include <cstring>

#include <iostream>

#include <vector>

#include <stack>

#include <cstring>

#include <string>

using namespace std;

 

//poj 1068

 

int produceS(int n, int* Psequence, char* tmpc) {

       int k = 0;

       for (int i = 1; i <= n; i++) {

              for (int j = 0; j<Psequence[i] - Psequence[i - 1]; j++)

                     tmpc[k++] = '(';

              tmpc[k++] = ')';

       }

       return k;

}

void solve(char* tmpc, int length) {

       stack<char> cstack;

       for (int i = 0; i<length; i++) {

              if (tmpc[i] == '(') { cstack.push('('); continue; }

              int ans = 1;

              while(!cstack.empty() && cstack.top() != '(')

              {

                     ans +=cstack.top() - '0';

                     cstack.pop();

              }

              cstack.pop();

              cstack.push('0' + ans);

              cout << ans;

              string tmp = i != length - 1 ? " " : "";

              cout << tmp;

       }

       cout << endl;

}

int main(int argc, char const *argv[])

{

       //freopen("in.txt","r", stdin);

       int caseTime;

       int n;

       int Psequence[50] ={ 0 };

       char tmpc[100];

       scanf("%d",&caseTime);

 

       for (int i = 0;i<caseTime; i++) {

              scanf("%d", &n);

              for (int j = 1; j <=n; j++)

                     scanf("%d",&Psequence[j]);

              int length =produceS(n, Psequence, tmpc);

              solve(tmpc, length);

       }

       return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值