PAT-1016 Phone Bills

gfd1016 Phone Bills (25)(25 分)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00

  • 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

 

题目较长,关键是理解题意,先按名字、日期排序,对所有同一用户连续出现的<on-line,off-line>对计算费用并输出,注意跨天费用计算

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef struct Record{
	char name[25];
	int day,hour,min;
	bool online;
}Record;
int month;
int rate[24]={0};
bool cmp(Record r1,Record r2){
	if(strcmp(r1.name,r2.name)!=0)
		return strcmp(r1.name,r2.name)<0;
	else{
		if(r1.day!=r2.day)
			return r1.day<r2.day;
		else{
			if(r1.hour!=r2.hour)
				return r1.hour<r2.hour;
			else{
				return r1.min<r2.min;
			}
		}
	}
}
int getFee(Record r1,Record r2,int *minutes){
	int fee=0;
	int day=r2.day-r1.day;
	int hour=r2.hour-r1.hour;
	int min=r2.min-r1.min;
	*minutes=day*60*24+hour*60+min;
	int h=r1.hour,m60=60-r1.min;
	for(int i=0;i<*minutes;i++){
		m60--;
		fee+=rate[h];
		if(m60==0){//one hour pass
			m60=60;
			h++;h=h%24;
		}
	}
	return fee;
}
int main(){
	int n;
	for(int i=0;i<24;i++)
		scanf("%d",rate+i);

	scanf("%d",&n);
	Record* list=(Record*)malloc(sizeof(Record)*n);
	char tag[10];
	for(int i=0;i<n;i++){
		scanf("%s %d:%d:%d:%d %s",&list[i].name,&month,&list[i].day,&list[i].hour,&list[i].min,&tag);
		if(tag[1]=='n')
			list[i].online=true;
		else
			list[i].online=false;
	}

	sort(list,list+n,cmp);

	int cents=0;char tname[25]={0};
	bool isNewP=0;bool lastIsOn=false;
	for(int i=0;i<n;i++){
		if(strcmp(tname,list[i].name)!=0){//new preson
			if(cents!=0)
				printf("Total amount: $%.2f\n",cents/100.0);
			strcpy(tname,list[i].name);
			cents=0;isNewP=true;
			lastIsOn=list[i].online;
			continue;
		}

		if(lastIsOn&&list[i].online==false){//match
			if(isNewP){
				printf("%s %02d\n",tname,month);
				isNewP=false;
			}
			int mins;
			int cent=getFee(list[i-1],list[i],&mins);
			cents+=cent;
			printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n",
				list[i-1].day,list[i-1].hour,list[i-1].min,
				list[i].day,list[i].hour,list[i].min,mins,cent/100.0);
		}
		lastIsOn=list[i].online;
	}
	if(cents!=0)
		printf("Total amount: $%.2f\n",cents/100.0);
	getchar();
	getchar();
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值