PAT-1098 Insertion or Heap Sort

 

1098 Insertion or Heap Sort (25)(25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. At each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

 堆排序是选择排序的改进,初始建大顶堆,从第一个有孩子节点开始adjust(),直到0号节点,大顶堆建成。adjust()函数将v号节点(其左右子树都是大顶堆)调整至恰当的位置,保持大顶堆。堆排序每次将堆顶最大元素与数组最后第i号元素互换,互换后adjust()一次,共执行n-1次后排序完成。

#include<stdio.h>

int n,a[100],t[100],b[100];
bool issame(){
	for(int i=0;i<n;i++)
		if(t[i]!=b[i])
			return false;
	return true;
}
bool insert(){
	bool same=false;
	for(int i=1;i<n;i++){
		int j=i-1,it=t[i];
		while(t[j]>it&&j>=0){
			t[j+1]=t[j];
			j--;
		}
		t[j+1]=it;
		if(same)
			return true;
		same=issame();
	}
	return false;
}
void adjust(int v,int size){
	int tmp=t[v];
	while(v<=size/2-1){
		int l=v*2+1,r=v*2+2,bigc;
		if(l<size)
			bigc=l;
		else break;

		if(r<size&&t[r]>t[l])
			bigc=r;
		if(t[bigc]>tmp){
			t[v]=t[bigc];v=bigc;
		}else break;
	}
	t[v]=tmp;
}
void buildHeap(){
	for(int i=n/2-1;i>=0;i--){
		adjust(i,n);
	}
}
bool heap(){
	buildHeap();
	bool same=false;
	for(int i=n-1;i>0;i--){
		int tmp=t[i];
		t[i]=t[0];t[0]=tmp;
		adjust(0,i);
		if(same)
			return true;
		same=issame();
	}
	return false;
}
int main(){
	scanf("%d",&n);

	for(int i=0;i<n;i++){
		scanf("%d",a+i);
		t[i]=a[i];
	}
	for(int i=0;i<n;i++){
		scanf("%d",b+i);
	}
	
	if(insert()){
		printf("Insertion Sort\n");
	}else {
		for(int i=0;i<n;i++){
			t[i]=a[i];
		}
		if(heap())
			printf("Heap Sort\n");	
	}
	for(int i=0;i<n-1;i++)
		printf("%d ",t[i]);
	printf("%d",t[n-1]);

	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值