1098 Insertion or Heap Sort

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9
Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9

解题思路:与插入与归并那题一样,先模拟插入排序,找中间过程有没有一样的,如果一直找不到就表示是堆排序的,未排序的部分中第一个一定是未排序的序列中最大的,堆是一棵完全二叉树,所以用数组就能完成的堆的创建,每次将未排序序列中的第一个元素与最后一个元素进行交换,然后对剩余的未排序序列进行堆调整就好。

#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
int main(){
    for (int n; scanf("%d", &n) != EOF;){
        vector<int>in(n);
        vector<int>comp(n);
        for (int i = 0; i < n; i++){
            scanf("%d", &in[i]);
        }
        for (int i = 0; i < n; i++){
            scanf("%d", &comp[i]);
        }
        vector<int>change(in);
        //判断是否是快速排序
        int flag = 1;
        for (int i = 2; i < n; i++){
            sort(change.begin(), change.begin() + i);
            flag = 1;
            for (int j = 0; j < n; j++){
                if (change[j] != comp[j]){
                    flag = 0;
                    break;
                }
            }
            if (flag){
                sort(change.begin(), change.begin() + i + 1);
                break;
            }
        }
        if (flag){
            printf("Insertion Sort\n");
            printf("%d", change[0]);
            for (int i = 1; i < n; i++){
                printf(" %d", change[i]);
            }
            printf("\n");
        }
        else{
            //说明是堆排序的
            int index = 0;
            for (int i = 1; i < n; i++){
                if (comp[i] > comp[0]){
                    index = i;
                    break;
                }
            }
            //将堆顶的数据与最后一个数据进行交换
            comp[0] = comp[0] ^ comp[index - 1];
            comp[index - 1] = comp[0] ^ comp[index - 1];
            comp[0] = comp[0] ^ comp[index - 1];
            //调整堆
            for (int i = 0; i < index - 1; i++){
                if (i * 2 + 1 < index - 1 && i * 2 + 2 == index - 1){
                    if (comp[i] < comp[i * 2 + 1]){
                        comp[i] = comp[i] ^ comp[i * 2 + 1];
                        comp[i * 2 + 1] = comp[i] ^ comp[i * 2 + 1];
                        comp[i] = comp[i] ^ comp[i * 2 + 1];
                    }
                    break;
                }
                if (i * 2 + 1 == index - 1){
                    break;
                }
                int left = comp[i * 2 + 1];
                int right = comp[i * 2 + 2];
                if (comp[i] < left || comp[i] < right){
                    if (right > left){
                        comp[i * 2 + 2] = comp[i];
                        comp[i] = right;
                    }
                    else{
                        comp[i * 2 + 1] = comp[i];
                        comp[i] = left;
                    }
                }
            }
            printf("Heap Sort\n");
            printf("%d", comp[0]);
            for (int i = 1; i < n; i++){
                printf(" %d", comp[i]);
            }
            printf("\n");
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值