PAT-1060 Are They Equal

1060 Are They Equal (25)(25 分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*10^5^ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10^100^, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d~1~...d~N~*10\^k" (d~1~>0 unless the number is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

将浮点数化为标准形式,,注意输入可能有形如  000500.43 ,  000001 出现,遇到0时应输出0.000……000*10^0

#include<stdio.h>
#include<string>
#include<string.h>
using namespace std;
typedef struct flo{
	int e;
	string num;
}flo;
int  n;
flo getstandard(char* ori){
	string s;
	int beginzero=0,zhshu=0;bool nopos=true;int dot=-1;
	for(int i=0;ori[i]!='\0';i++){
		if(ori[i]=='.')
		{dot=i;continue;}
		if(nopos&&ori[i]=='0')
		{beginzero++;continue;}


		nopos=false;
		s+=ori[i];
	}
	if(dot<0)
		zhshu=strlen(ori)-beginzero;
	else{
		zhshu=dot-beginzero;
	}
	if(s.size()==0)//0
		zhshu=0;

	while(s.size()<n)
		s+='0';
	s=s.substr(0,n);

	flo f;
	f.num=s;f.e=zhshu;
	return f;
}
void print(flo f){

	printf("0.%s*10^%d",f.num.c_str(),f.e);
}
int main(){

	char a[105],b[105];
	scanf("%d %s %s",&n,a,b);

	flo f1=getstandard(a);
	flo f2=getstandard(b);

	if(f1.e==f2.e&&f1.num==f2.num){
		printf("YES ");
		print(f1);
	}else{
		printf("NO ");
		print(f1);
		printf(" ");
		print(f2);
	}

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值