1060. Are They Equal

Are They Equal

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (< 100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line “YES” if the two numbers are treated equal, and then the number in the standard form “0.d1…dN*10^k” (d1>0 unless the number is 0); or “NO” if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

题意

给定两个数,保留n位有效数字并用科学计数法表示(不进行舍入),判断变换后的两个数是否相等,并按照不同情况的指定格式进行输出。

思路

直接用字符串进行处理,判断主要根据两部分:n位小数是否相等,以及指数是否相等,关键是要对给出的数进行去’0’处理。


代码实现

#include <iostream>
#include <string>
using namespace std;

string solve(string s, int &exp, int acc)
{
	string ans = "0.";
	int i = 0;
	exp = 0;
	
	while(s[0] == '0')          // 先去'0'
		s.erase(0, 1);
	
	if (s[0] == '.')            // 第一次去'0'后若直接为小数点,则该数小于1
	{
		s.erase(0, 1);          
		while (s[0] == '0')     // 去除小数点后的'0',每去一个'0'指数减1
		{
			s.erase(0, 1);
			exp--;
		}
	}
	else        // 该数大于1时
	{
		while (s[i] != '.' && i < s.length())       // 寻找小数点
		{
			exp++;
			i++;
		}
		if (s[i] == '.')        // 若存在小数点则去掉
			s.erase(i, 1);
	}
	if (s.length() == 0)        // 若字符串剩余长度为0,说明该数为0,指数置为0
		exp = 0;	
	
	i = 0;
	while (i < acc)             // 当精度不足时
	{
		if (i < s.length())     // 若剩余字符串中还有数字
			ans += s[i++];
		else                    // 数字不够末位补'0'
		{
			ans +='0';
			i++;
		}
	}
	ans = ans + "*10^";
	
	return ans;
}

int main()
{
	int n;
	string a, b;
	string x, y;
	int xe, ye;         // 存储指数
	
	cin >> n >> a >> b;
	x = solve(a, xe, n);
	y = solve(b, ye, n);
	
	if (x == y && xe == ye)     // 既要小数部分相等,也要指数相等
		cout << "YES " << x << xe;
	else
		cout << "NO " << x << xe << " " << y << ye;	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值