POJ 2247

 
Humble Numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3399 Accepted: 1587

Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence.

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

Source

—————————————————————————————————————————————————
难度:1      代码量: 1    分类: 基本
分析:
一个humble数的{2,3,5,7}的积一定是一个humble,那么找出他们其中最小的作为新的humble。
为了加快搜索过程,可以使用一个素数集大小的数组记录这个素数与某个humble的积<=当前最大humble的最大的位置,这样可以过滤掉小的数,而且这个最大的humble的位置的下一个数和这个素数的乘积就是这个素数能产生的最小的未生成的humble,比较每个素数能产生的最小的humble,选一个最小的作为新的humble。
代码:
#include  < stdio.h >
int  main()
{
    
int num[5842]={1};
    
int a[4]={0};
    
int prime[4]={2,3,5,7};
    
int min;
    
int count=0
    
int i,n;    
    
    
for(count=1;count<5842;count++)
    
{
        
for(i=0;i<4;i++)
        
{
             
if(num[a[i]]*prime[i]<=num[count-1])
                a[i]
++;
        }

        min
=2000000001;
        
for(i=0;i<4;i++)
        
{
            
if(prime[i]*num[a[i]]<min)
            
{
                min
=prime[i]*num[a[i]];                
            }

        }

        num[count]
=min;
                
    }

    
while(scanf("%d",&n),n)
    
{
        
if(n%10==1&&n%100!=11)
                         printf(
"The %dst humble number is %d. ",n,num[n-1]);
                             
else if(n%10==2&&n%100!=12)
                         printf(
"The %dnd humble number is %d. ",n,num[n-1]);
                                           
else if(n%10==3&&n%100!=13)
                         printf(
"The %drd humble number is %d. ",n,num[n-1]);
                             
else
                         printf(
"The %dth humble number is %d. ",n,num[n-1]);
    }
    
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值