PAT A1048 Find Coins

1048 Find Coins
分数 25
作者 CHEN, Yue
单位 浙江大学
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10 
5
  coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (10 
5
 , the total number of coins) and M (10 
3
 , the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.


Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution

解析:本题采用散列表存储所有数字的出现频率,然后针对每一个数字a查找M-a是否存在即可。需要注意的有两点:

  1. 在使用数组作为散列表时,必须保证下标本身不能越界
  2. 当M-a=a时,必须保证a至少出现了两次及以上
#include<iostream>
#include<cstring>
using namespace std;
int main(){
	int number, target, temp;
	int hashtable[10010] = { 0 };
	cin >> number >> target;
	for (int i = 0;i < number;i++) {
		cin >> temp;
		hashtable[temp]++;
	}
	for (int i = 0;i < 1005;i++) {
		int sub = target - i;
		if (sub>=0) {//注意target-i必须为正整数,否则访问下标出错或无意义
			if (hashtable[i]>0 && hashtable[sub]>0) {
				if (i != sub) {
					cout << i << " " << sub;
					return 0;
				}
				else if (i == sub && hashtable[sub] > 1) {
					cout << i << " " << sub;
					return 0;
				}
			}

		}
	}
	cout << "No Solution" << endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值