NBUT1218 You are my brother

  • [1218] You are my brother

  • 时间限制: 1000 ms 内存限制: 131072 K
  • 问题描述
  • Little A gets to know a new friend, Little B, recently. One day, they realize that they are family 500 years ago. Now, Little A wants to know whether Little B is his elder, younger or brother.
  • 输入
  • There are multiple test cases.
    For each test case, the first line has a single integer, n (n<=1000). The next n lines have two integers a and b (1<=a,b<=2000) each, indicating b is the father of a. One person has exactly one father, of course. Little A is numbered 1 and Little B is numbered 2.
    Proceed to the end of file.
  • 输出
  • For each test case, if Little B is Little A’s younger, print “You are my younger”. Otherwise, if Little B is Little A’s elder, print “You are my elder”. Otherwise, print “You are my brother”. The output for each test case occupied exactly one line.
  • 样例输入
  • 5
    1 3
    2 4
    3 5
    4 6
    5 6
    6
    1 3
    2 4
    3 5
    4 6
    5 7
    6 7
    
  • 样例输出
  • You are my elder
    You are my brother
  • 来源:辽宁省赛2010
    
    提交时总是TLE   所以试着把cin改成scanf  结果AC了   ~~
     代码:
#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
 int n,i,j,k;
 int la,lb,a,b;
 while(scanf("%d",&n)!=EOF)
 {
     la=1;lb=2;a=0;b=0;
  for(k=0;k<n;++k)
  {
      scanf("%d%d",&i,&j);
      if(la!=lb)
      {
                if(i==la)
                {
                    la=j;
                    a++;
                }
                if(i==lb)
                {
                    lb=j;
                    b++;
                }
      }
  }
 if(a<b)
           cout<<"You are my younger"<<endl;
        else if(a==b)
           cout<<"You are my brother"<<endl;
        else if(a>b)
           cout<<"You are my elder"<<endl;
 }
 return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值