HDU - 1160----FatMouse's Speed

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that

W[m[1]] < W[m[2]] < … < W[m[n]]

and

S[m[1]] > S[m[2]] > … > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
4
4
5
9
7

题意:给出n个老鼠的重量和速度值(先重量后速度),要求给出一个最长的排列,其中,前一只老鼠的重量严格小于后一只老鼠,而它的速度要严格大于后一只老鼠。输出,序列长度,老鼠的标号。

思路:
最长子序列的变形
先对重量排序,将问题降为最长子序列
然后dp[i]表示以i结尾的满足要求的最长序列

#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<algorithm>
using namespace std;
const int MAX=1008;

struct node{  
    int w,v;//重量和速度  
    int id;//编号  
}A[MAX];  

int pre[MAX];//序列下标 
int dp[MAX];



//重量从小到大排序,同重量排速度 
bool cmp(node a,node b){
    if(a.w == b.w){  
        return a.v>b.v;  
    }else{
        return a.w<b.w;
    }
}  


//递归逆序输出序列 
void print(int index){  
    if(index != -1){  
        print(pre[index]);  
        cout<<A[index].id<<endl;
    }  
}  

int main(void){  
    int ind=0,index=0,ans;  
    while(scanf("%d%d",&A[ind].w,&A[ind].v) != EOF){  
        A[ind].id = ind+1; 
        ind++; 
    }  
    sort(A,A+ind,cmp);

    dp[0]=ans=1,pre[0] = -1;  
    for(int i=1 ; i<ind ; i++){  
        //初始长度为1 
        dp[i]=1;pre[i]=-1;
        //更新长度   
        for(int j=0 ; j<i ; j++){  
            // 避免同重量的      速度递减          长度增加 
            if(A[j].w<A[i].w && A[j].v>A[i].v && dp[j]+1>dp[i]){  
                    dp[i]=dp[j]+1;  
                    pre[i] = j;
            }  
        }  
        if(ans < dp[i]){
            ans = dp[i];
            index = i;
        }
    }  

    cout<<ans<<endl;  
    print(index);  

    return 0;  
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值